My FireWire 800 port is not working

Discussion in 'iMac' started by kwfl, Feb 1, 2008.

  1. kwfl macrumors 6502

    Joined:
    Aug 20, 2007
    #1
    hello, i got an aluminium imac. however, today when i tried to connect my FW800 Hard drive it did not work and it works by FW400. i connect the same Drive to my MBP using FW800 and it is working flawlessly.

    i am still running tiger while the MBP has leopard


    anyone can guess what could be the problem?

    thanks.

    i wonder wether the returned My Book Studio has any effects on this. i returened it because i couldnt get it to connect via firewire. i really hate this as i use that lovely FW800 port a lot.
     
  2. kwfl thread starter macrumors 6502

    Joined:
    Aug 20, 2007
  3. CycloneGary macrumors newbie

    Joined:
    May 1, 2009
    #3
    Easy solution works!

    After several days of hand-wringing, wondering why my WD My Book External drive would mount on our older system in the office but not on my new iMac at home, I searched some forums and found this very easy solution, which worked on the first try. This problem arose suddenly out of the blue. It worked fine one day and did not appear the next.

    Thanks for pointing out this easy fix!
     
  4. kcpenner macrumors newbie

    Joined:
    Apr 18, 2008
    #4
    It worked - thanks

    Shut down the computer.
    Unplug the computer's power cord.
    Press and hold the power button for 5 seconds.
    Release the power button.
    Attach the computers power cable.
    Press the power button to turn on the computer.

    Woo ... Voodoo ... but hey, I'm a believer now!
     
  5. rblows macrumors newbie

    Joined:
    Jan 4, 2010
    #5
    Same problem. Followed the instructions

    Still no joy.
    I was told that it may need a replacement board which will cost in the region of about £700.
    Better of adding a few more pounds and get a new imac, which is a big outlay.
    It looks like I'm stuck with using the USB which defeats the object of getting the firewire drive.

    Any further ideas would be appreciated.
     
  6. asknone9 macrumors newbie

    Joined:
    Oct 21, 2009
    #6
    This is a bigger issue than you think, for which Apple and individual manufacturers have not provided a solution yet. In fact, only Freecom have acknowledged there is a problem. Western Digital, last time I checked, were "investigating the issue." Check this out before you go getting things replaced, as it may help you: http://discussions.apple.com/thread.jspa?threadID=2136580&tstart=0
     
  7. urban videos macrumors newbie

    Joined:
    May 26, 2010
    #7
    Unplugging worked!?

    Thank you, guys! I was about to send back a drive because it was working with all the ports in my iMac except for the FW 800. This was the first link that popped up on a search for FW 800 port died, and I really appreciate the tip on shutting down, unplugging, pressing power for 5 secs, then starting up again. (I had shut down the computer a dozen times trying to troubleshoot this, but for some reason, the unplugging and/or the pressing of the power button while unplugged worked!) I tried looking through the Apple forums, but I burned out on page 3 out of the 15 pages of complaints and suggestions. THANK YOU for posting in brief here!
     
  8. makaha50 macrumors newbie

    Joined:
    Sep 3, 2009
    #8
    nice.

    thanks kwfl. i was assuming this iomega ego 1tb was bunk, but i'm happily transferring files to it after resetting the SMC. i wish more issues would resolve this easily.

    cheers,
    /makaha
     
  9. csteelooper macrumors newbie

    Joined:
    Feb 27, 2011
    #9
    Hi, first post here.
    I had the same issue with my WD My Passport Studio 500GB. The drive itself didn't seem quite as reliable as I'd have hoped right from the off (transfers ceasing up halfway through on all computers (Mac and Windows) and connections (USB; FW400/800)), but when I went to Windows (Boot Camp) to figure out if there'd be different behaviour, Windows felt like detecting the entire FW subsystem again. It failed. I was frustrated, because now I didn't even 'see' my other (Time Machine) drive either.
    I rebooted into Mac OS X. No drives. I hooked the entire chain of devices up to the FW400 port. The devices showed. Back to 800 after unmounting normally. No devices.
    I then powered everything down and waited a quarter of an hour. After starting Mac OS X, everything worked. In between I did a power cycle and a PRAM/SMC Reset to no avail. The only thing that seemed to have worked was the 15 minute power down. What could have been the matter?
    I still don't understand it, and am now very careful to power down all FW devices before booting Windows (I don't need those there anyway
     
  10. mstapleton, Jul 10, 2011
    Last edited: Jul 10, 2011

    mstapleton macrumors newbie

    Joined:
    Jun 18, 2009
    #10
    Press and hold the power button for 5 seconds is not actually part of that service doc. It simply says to wait 5 secs after plugging in to restart. But if it works for ya, hey.
     
  11. garthd macrumors newbie

    Joined:
    Sep 26, 2011
    #11
    Imac Firewire Port Not Reading

    Thanks to the person with tip; 'hold power button down 5 sec with the power cord out' - it worked! I've read some pretty complicated threads on the issue, funny that the fix was so simple.
    Cheers,
    g.
     
  12. radiosound macrumors newbie

    Joined:
    Nov 19, 2011
    #12
    Wow!

    Guys, thank you so much. You saved me a whole bunch of logistical challenges to pack this mac up and get it to a repair shop. I was dumbfounded as to why my existing and new backup drives weren't showing up.

    Solved!

    Thanks again.
     

Share This Page