My first Mac problem...usb port stopped working

Discussion in 'iMac' started by bluedoggiant, Apr 13, 2009.

  1. bluedoggiant macrumors 68030

    bluedoggiant

    Joined:
    Jul 13, 2007
    Location:
    MD & ATL,GA
    #1
    I have had my 24" 2.8GHz iMac from November 2007 flawless until today, 1 of 3 usb ports on the back simply decided to stop working. my keyboard, when plugged in, does not work, however, I usually use this one port with my iPod, when I plug my iPod in, it turns on, says its connected, then ejects automatically, though in the other ports...it works fine in the other ports.

    Any ideas what could be the problem? This is really unfortunate for me :(
     
  2. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #2
    hey man! you ahvent been on msn lately - or maybes you deleted me.. anyway lol

    have you tried the hardware diagnostics test?? its a very odd occurence for just one to stop working....
     
  3. trevpimp macrumors regular

    trevpimp

    Joined:
    Apr 16, 2009
    Location:
    Inside A Mac Box
    #3
    If it still doesnt work then hopefully your warranty is still good.

    As long as you have a warranty still in date.
     
  4. YanniDepp macrumors 6502

    YanniDepp

    Joined:
    Dec 10, 2008
    #4
    I had an issue like this once. Strangely enough, it started working again when I rebooted.

    If you've rebooted since it stopped working (and I know a lot of people that leave their macs on 24/7), try resetting the PRAM.

    If those don't work, it's definitely a hardware issue.
     

Share This Page