Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

VideoNewbie

macrumors 6502
Original poster
Feb 6, 2009
476
6
so earlier i was trying to place font within a GIF pic and it wouldnt let me i converted the pic to a png

ever since i did that any time i try to add text to an image whether its a jpg or png or psd the font looks very pixeled and low res

i thought it might be my color settings so i changed it from 8 bit to 32 bit and the problem still exists
i dont even remember if 8 or 32 is the default ?

any ideas what happened?
 

PrePressAcrobat

macrumors member
Nov 2, 2010
64
1
so earlier i was trying to place font within a GIF pic and it wouldnt let me i converted the pic to a png

ever since i did that any time i try to add text to an image whether its a jpg or png or psd the font looks very pixeled and low res

i thought it might be my color settings so i changed it from 8 bit to 32 bit and the problem still exists
i dont even remember if 8 or 32 is the default ?

any ideas what happened?



-----

1 - ANY vectors will 'look" rasterized when viewed in Photoshop - no matter what.

2 - When using vectors inside Photoshop
there are only 2 ways to get vectors OUT of Photoshop.

A - Save as Photoshop .eps file
these files can be placed into InDesign and be spit out as PDF as
print files to RIP and retain their vectors.
Or, as PostScript files, they can be registered directly to the RIP.
However ... these files will ALWAYS rasterize when reopened with photoshop
so ... this is worthless and not recommended as no editing is possible.

You could always start over with the .psd file.

B - Save as Photoshop PDF (please manually change the extension to .pdp
after the "save as" to identify the file for your and your PrePress providers clarification in the future.
These files may be placed into InDesign, registered to the RIP and
reopened with Photoshop while retaining all of the layers and vectors.
--
When using type inside Photoshop ...
DO NOT use "Faux Bold" or "Faux Italic"
(as in right clicking on the type and selecting these).
You MUST have loaded and use the actual font - Bold and Italic -
from the font popup menu.
If you use the "Faux" styled fonts:
the ENTIRE TEXT BOX will instantly be rasterized - no matter what.
--
Any other Photoshop will print rasterized.
A .psd file will rasterize (instantly) when placed into InDesign
(no matter what).

MSD
 
Comment

VideoNewbie

macrumors 6502
Original poster
Feb 6, 2009
476
6
-----

1 - ANY vectors will 'look" rasterized when viewed in Photoshop - no matter what.

MSD

thanks but you just gave me a l aundry list of what seems to be somewhat complicated work arounds such as having to save the photoshop as a esp file and speaking a language i am too illiterate in photoshop to understand.

all i know is in the past i fired up photoshop and was easily able to input text without it looking 'rasterized'
in the past as early as this morning there were no issues when entering text it would just work easily and simply.

any other ideas?
 
Comment

Macsonic

macrumors 68000
Sep 6, 2009
1,627
63
so earlier i was trying to place font within a GIF pic and it wouldnt let me i converted the pic to a png

ever since i did that any time i try to add text to an image whether its a jpg or png or psd the font looks very pixeled and low res

i thought it might be my color settings so i changed it from 8 bit to 32 bit and the problem still exists
i dont even remember if 8 or 32 is the default ?

any ideas what happened?

To clarify, what error message are you getting when you say the Gif image cannot be converted to PNG? Not sure if this helps, can you try to go to Image/Mode and check if the word "Index" is checked/highlighted? If "Index" is checked, change it to "RGB".

Will you be using the PNG for web viewing or for a high res print material? For the font being pixelated, maybe try to go to the top menu bar where you see the font character, size, etc and on the right there is a dropdown menu with "None, Sharp, Crisp, Strong and Smooth" Try setting the font to either Crisp, strong. Though not sure if this will help solve your inquiry.
 
Comment

VideoNewbie

macrumors 6502
Original poster
Feb 6, 2009
476
6
nevermind guys. the solution was very simple

found this elsewhere

"
Open the little menu in the Character Palette (little triangle, top right) and scroll down to "Reset Character", then try again."
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.