My force click isn't working properly?

Discussion in 'MacBook' started by nearlycried, May 21, 2015.

  1. nearlycried macrumors newbie

    Joined:
    May 3, 2015
    #1
    Basically I'm on safari and for the past day (after having the Laptop like 2 weeks) I can't force click to show a preview of links or look up a word?

    Force click is still there and I can turn it on and off through settings and tried messing round in there but Force click is working and the functions are not?
    Every time i force click on a link it just opens the link now?

    Probably me doing something dumb so any ideas?
     
  2. Dwayne82 macrumors member

    Joined:
    May 16, 2015
    Location:
    Switzerland
    #2
    Hi
    In the Trackpad-settings, the "Lookup & data detectors" should be Activated and set to "Force click with one finger". Otherwise, (on "click or tap with three fingers") the Trackpad behaves as you described.

    [​IMG]
     
  3. nearlycried thread starter macrumors newbie

    Joined:
    May 3, 2015
    #3
    Thanks for your reply I already had that setting on though.
    My force click works in previewing folders, just not on safari anymore it seems?

    Are there any settings in Safari that would affect that or just a bug?
     
  4. infernoguy macrumors regular

    infernoguy

    Joined:
    Jun 24, 2011
    Location:
    Nashville, TN
    #4
    This happened to me when I got my rMBP 13 2015. Quit out of Safari and restart it. That fixed it for me.

    You may have to reboot if that doesn't work...
     
  5. nearlycried thread starter macrumors newbie

    Joined:
    May 3, 2015
    #5
    Yeah weird it works now, didn't even have to quit safari just randomly started working in the middle of chatting online to Apple help, very embarrassing
     

Share This Page