My Fusion Drive Got Slow, How I Fixed It

Discussion in 'iMac' started by DerekS, Dec 22, 2013.

  1. DerekS macrumors 6502

    Joined:
    Jun 25, 2007
    #1
    My speeds were getting terrible (Dec 2012 model, factory 1TB Fusion.)

    I was seeing < 100MB/sec in both directions.

    I rebooted to single user mode (command-S during boot) and at the prompt entered:

    fsck -ffy

    One of the messages that scrolled by was "trimming unused blocks."

    After the reboot, my speeds were back to factory fresh!

    202MB/sec write, 352MB/sec read

    Just wanted to share this tip if others feel like their Fusion drive is starting to suck! My guess is that OSX fails to trim the SSD on its own.
     
  2. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #2
    Very interesting! Have you checked to see if OS X reports trim enabled in the System Information utility for that drive? (Hardware-->SATA, under the SSD info look for "TRIM Support: Yes")?

    Also, are the two "f" characters on your fsck command a typo? Looking at the man page it seems a single "f" option is sufficient. (There's also a scary warning about the "y" option!)

    Thanks for the info, I'll keep it filed away. That's a big performance increase.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    He has a factory Fusion drive, so TRIM would be enabled. And you are correct "fsck -fy" will do the trick.
     
  4. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #4
    Interesting. I doubt the trimming is the reason, though.

    It's not a bad idea to occasionally boot into the recovery partition (hold cmd-R down during boot) and run Disk Utility's repair and permissions-repair functions. This would be safer than futzing around in Terminal.
     
  5. DerekS thread starter macrumors 6502

    Joined:
    Jun 25, 2007
    #5
    Yes, factory SSD (factory Fusion, really) and TRIM does show enabled.

    I am convinced that trimming made the speed improvement, as I had already run repair permissions and such in Disk Utility many times prior.

    My conclusion is that OSX does not automatically trim Fusion drives.
     
  6. rbart macrumors regular

    Joined:
    Nov 3, 2013
    Location:
    France
    #6
    I have tried many times to make my DIY Fusion drive work on my iMac (Lacie TB SSD + internal hard drive).
    It works after a fresh install with good write perf, but after few days, write perfs are getting bad (50Mb/s with blackmagic).
    I suspect something with TRIM (it's supposed to be active on my Mac) but ...
     
  7. andycho7 macrumors member

    Joined:
    Dec 2, 2013
    #7
    Did you manually enable the TRIM? I did a DIY fusion drive on my 2011 iMac 27 inch with 250GB Samsung Evo. Right after the OS installation, I checked the system report and TRIM wasn't enabled by default.
     
  8. shaunp macrumors 65816

    Joined:
    Nov 5, 2010
    #8
    Perhaps raise it as a bug with Apple?
     
  9. rbart macrumors regular

    Joined:
    Nov 3, 2013
    Location:
    France
    #9
    Yes, it's enabled with Trim enabler.
     

Share This Page