My Hard Drives Locked themselves and Won't Unlock!

Discussion in 'Mac Basics and Help' started by mattso, Sep 16, 2010.

  1. mattso macrumors newbie

    Joined:
    Sep 16, 2010
    #1
    YEAH...
    Hope someone can help...
    Our Mac Pro crashed, and upon reboot, both the internal raid as well as the external firewire drive that happened to be plugged into the machine at the time, are both 'locked' and we cannot unlock them. We've tried toggling the 'user and permission' choices from the 'custom' setting that they are now showing to read/write... and it just snaps back to 'custom'!
    Same if we try to change to just READ or just WRITE...etc...nothing...
    Just a gray icon of a LOCK under the icons of the drives, and a warning anytime I try to access them, saying I don't have permission to do so.

    I even unplugged the firewire drive and plugged it into another computer and it does the same thing!
    And I even made a new ADMIN and tried changing it with that, to no avail.
    Everytime I look at either of these drives, those 'users and permissions' toggles are back at 'custom' and they just won't relent!

    Oh, and I also flashed PRam and 'Repaired permissions' on the boot drive [yes, the boot drive is working fine]

    I need the media that is on these drive... a ton of video media on the internal raid, specifically... So I can't just repartition them from boot disk.

    Anyone have any ideas?

    Thanks!
     
  2. Ozric macrumors newbie

    Joined:
    Jul 22, 2004
    Location:
    NJ
    #2
    How about formatting new drives equal to or greater in size, and copy the contents over to them?
     
  3. designs216 macrumors 65816

    designs216

    Joined:
    Oct 26, 2009
    Location:
    Down the rabbit hole
    #3
    I ran into a similar problem a couple days ago where although I am the Admin, the drive had me locked out. I did a boatload of digging and found a post that used Terminal commands to repair the permissions. Let me see if I can find that handy info again...

    Try this, it worked for me:
    http://forums.macrumors.com/showthread.php?t=417647&highlight=ACL&page=2
     
  4. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
  5. mattso thread starter macrumors newbie

    Joined:
    Sep 16, 2010
    #5
    Yay

    Thanks guys!
    Designs216 - that thread nailed it. The 'sudo' commands in the terminal were exactly what the guru I ended up paying to fix it used.

    See ya guys..
    m
     

Share This Page