My icons are turning into blank white squares?!

Discussion in 'Jailbreaks and iOS Hacks' started by Baggy Spandex, Oct 3, 2010.

  1. Baggy Spandex macrumors 6502

    Baggy Spandex

    Joined:
    May 23, 2009
    #1
    So, all of a sudden at some point yesterday, 3 or 4 of my App store icons just turned white. The apps worked perfectly still, but the icon art was gone!

    Has this happened to anyone else? I had to reinstall the apps from the App store, and while inconvienient because I lost data, it fixed the issue.
     
  2. FamiliaPhoto macrumors 6502a

    FamiliaPhoto

    Joined:
    Jul 24, 2009
    Location:
    Chicago, IL
    #2
    Are you using a theme with WinterBoard? If so I have seen this happen when an app updates and the old bundle or icon name are no longer correct in the theme.
     
  3. Bandolier macrumors 6502a

    Joined:
    Aug 2, 2010
  4. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #4
    The last time this happened to me, it turned out it was a problem with the png file's permissions. This was with themed icons, btw. The correct permissions should be 644 IIRC.
     
  5. ajnicho macrumors 6502a

    Joined:
    Sep 24, 2008
    #5
    Yep that happened to me a couple of times and I am not even jailbroken. A quick reboot fixed it
     
  6. fsck-y dingo macrumors 65816

    fsck-y dingo

    Joined:
    Jun 14, 2009
    #6
    Baggy,

    Do you happen to have biteSMS installed on your phone. A few people have had something similar happen and one common app is biteSMS. They say after sending or receiving a text the app store application icons turned white.

    I have biteSMS but nothing like that has happened to me so far. I recently switched from the current release version 4.99 to their 5.0 beta. Those having trouble were running 4.99 so I figured I'd give the new one a try. :)

    Here's the thread about what I mentioned above. I hope this helps.

    http://forums.macrumors.com/showthread.php?t=998157
     
  7. Barneygumble47 macrumors regular

    Joined:
    Aug 1, 2010
    Location:
    N. Ireland
    #7
    I had this problem and I used iwipe to solve it.
     
  8. Baggy Spandex thread starter macrumors 6502

    Baggy Spandex

    Joined:
    May 23, 2009
    #8
    Sorry for the late return to my own thread!

    Problem has not happened again...yet. I do not have Winterboard or BiteSMS installed on my phone, so no issues there. I rebooted at first, but it didn't fix my issue. Weird.

    And Bandolier, it was similar, only instead of a blank app, there was a white icon. Just solid white.
     
  9. Omn12 macrumors newbie

    Joined:
    Feb 27, 2011
    #9
    Help

    The exact same thing happened to me
    I still can't get it to work
    A lot of the icons are blank white boxes on my iPad
    Please someone help
    I tried ot redraft and sync but the same thing happened:confused:
     
  10. Xhita macrumors member

    Joined:
    Nov 2, 2010
    Location:
    Switzerland
    #10
    I suggest you try the iPad Hack forum. This one is only for the iPhone...
     
  11. tiggafputuhs macrumors newbie

    Joined:
    Apr 10, 2012
    #11
    Fixed

    This is not a tested solution, but I had the issue on my iPad. What I did to resolve the issue is put the affected apps into a folder and the icons come back. Not sure why, I guess it refreshes them or something.
    Hope it helps!

    5.0.1OS
     
  12. brittlewis12 macrumors newbie

    Joined:
    Apr 10, 2012
    Location:
    Washington, DC
    #12
    That happens pretty frequently for me when installing new Cydia apps/tweaks. A simple respring should do the trick!
     
  13. HickDead macrumors 6502a

    HickDead

    Joined:
    Dec 2, 2011
    #13
    +1. This is the correct and most simple way to fix it. Very common issue.
     
  14. JT17 macrumors newbie

    Joined:
    Oct 18, 2011
    #14
    Or even if you have Springtomize, you can just hit the Reload Settings so that you don't have to respring. :p
     
  15. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
  16. nwmtnbiker macrumors 68000

    nwmtnbiker

    Joined:
    Apr 5, 2011
    Location:
    Fidalgo Island
    #16
    I always used sbsettings Fix User Dir Permissions. Sbsettings/More/System Options.
     

Share This Page