My iMac has sleeping problems

Discussion in 'iMac' started by bungiefan89, Jul 10, 2011.

  1. bungiefan89 macrumors 6502a

    Joined:
    Apr 5, 2011
    #1
    2011 27" iMac with the 3.4 processor. She does go to sleep on occasion, like when I manually tap the power button, but she has trouble staying asleep sometimes.

    I also believe that the 'auto sleep after X time' feature in Energy Saver isn't working quite right. My screen will go dark and then turn off, but she's not asleep as I can hear the computer humming quietly unlike the absolute silence during sleep mode.

    It's lead to quite a few annoying situations where I come back to my computer after a number of hours and find that it hasn't been sleeping since last I left it. I just don't want to be burning up so much electricity.

    Any one else experiencing this? Tips for solving issue?
     
  2. trip1ex macrumors 68000

    Joined:
    Jan 10, 2008
    #2
    I've solved this issue a few times. There's lots of info on web.

    Some say it's a corrupted related preference file. Delete the right ones and reboot and see if issue goes away. Apple has a support doc on this. Never fixed my sleep problem.

    In my case (first time I had this problem,) it was my printer queue that was the cause. It still had a document in it for a printer that I had disconnected from my Mac and stopped using. This kept my iMac awake. Deleting it fixed the problem.

    The last time my iMac stopped sleeping I tried everything to fix it. Nothing worked. Finally I decided to reinstall. I was thinking that maybe this problem crept up when I upgraded to Snow Leopard because I did a clean install from the SL disc. And not from my original included Leopard disc.

    My thinking was something on the original Leopard disc was needed. Some original hardware driver of some kind that was missing on the SL disc or slightly changed. So I did a clean install from my original iMac Leopard disc and then upgraded to SL from there.

    And the problem went away. But I also didn't automatically transfer all my programs and data over either and so some stuff never was transferred over. And that could have been really why the problem went away. Don't know. But it worked.
     
  3. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #3
    Can you link that Apple Support Doc? I seem to have trouble finding it.

    Thanks in advance.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    http://docs.info.apple.com/article.html?path=Mac/10.5/en/9040.html
     
  5. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #5
    Wirelessly posted (iPhone 3GS: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    Did you look under System Preferences --> Energy Saver and see if "wake for Ethernet LAN access" is checked? I think that's what it's called, pulling from memory anyway. If it's checked and you don't need to wake the 'puter via the LAN, then uncheck it and see if she stays asleep.
     
  6. bungiefan89 thread starter macrumors 6502a

    Joined:
    Apr 5, 2011
    #7
    Neither of these links worked for me unfortunately.

    I even tried unchecking everything in Energy Saver, setting the sleep time down to 1 minute, and unplugging everything from the iMac. After 2 minutes, the computer's display had gone to sleep, but the computer itself was still clearly not asleep. And I did try checking pmset -g in terminal, everything's fine.

    So why won't my computer go to sleep on its own? I paid well over 2 grand for this thing...
     
  7. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #8
    So you're saying that there's a connection to Sleep and the price you pay for your Mac?

    Seriously, I've had the same off and on issue as you with my 2011 iMac. I've just learned to put up with it. In the grand scheme of things, for me, it's just not that big an issue. i wind up shutting my Mac down when I know I'm not going to be using it for a few hours.

    If you had sleep issues with a laptop, I could see the concern.
     
  8. fredou macrumors newbie

    Joined:
    May 21, 2011
    #9
    +1 I have also this issue on iMac 2011 and Lion.
     
  9. iSayuSay macrumors 68030

    iSayuSay

    Joined:
    Feb 6, 2011
    #10
    I also have a bit of problem with OSX sleep mode. It has been too sensitive.

    Whenever I try to unplug USB/Firewire devices out of iMac while it's sleeping .. it always wakes up .. since Lion there has been a fix though, the screen keep turned off (it wasn't on SL) while I'm doing this, but still woken up nonetheless, I can hear the hdd and fans spinned up.

    Ironically, my Windows bootcamp doesn't do this on sleep mode. It only wakes when I press any key on mouse/keyboard or trackpad physical button.

    Well that's what I want .. plain and simple :D
     
  10. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #11
    Three of the four systems I upgraded to Lion no longer go to sleep based on the sleep timer (they will manually sleep). The forth may also not be sleeping, but it is an Air which is totally silent anyway and I can't tell if it is sleeping or not.

    Solved the problem with the program PleaseSleep, which I'll continue to use until Apple fixes this obvious Lion bug.

    Report all problems to Apple feedback!

    http://www.apple.com/feedback/macosx.html
     
  11. product26 macrumors 6502a

    product26

    Joined:
    May 30, 2005
    #12
    Do you have a magic trackpad? My iMac will not sleep at all if the "allow bluetooth devices to wake this computer" option enabled.
     
  12. bungiefan89 thread starter macrumors 6502a

    Joined:
    Apr 5, 2011
    #13
    I forgot to mention in my previous post... I not only unplugged everything from my computer, but I also turned Bluetooth off as well as Wi-Fi. And I don't have a magic trackpad. I only have a magic mouse, and it's stored away in a cupboard turned off.

    So, yeah, I'm pretty sure that's not the problem, but thanks for the idea.
     
  13. coolbass macrumors newbie

    Joined:
    May 6, 2010
    #14

    There was for me only one solution that seemed to work, logging out and then sleep.
     
  14. annie123 macrumors newbie

    Joined:
    Aug 24, 2011
    #15

    thanks a lot for this suggestion.
     
  15. flover21 macrumors newbie

    flover21

    Joined:
    Jun 21, 2011
    Location:
    Kyiv
  16. Chris Alger macrumors newbie

    Joined:
    Sep 1, 2011
    Location:
    Sydney, Austrlaia
    #17
    my iMac sleeps better now....

    I had a lot of trouble with my iMac waking twice or more through the night. I was always aware of it because I sleep in the same room as my iMac (and mobile phone). I tried many things to solve the problem but what seems to have worked is to switch off my mobile phone or put it into 'airplane' mode (switch off its aerials).

    Mobile phones occasionally 'handshake' with the nearest tower when switched on (even when not in use). These transmissions can create electric currents in nearby circuitry by induction. I'm quite sure (by a process of elimination) that this is what has been waking my iMac from sleep. Currents created in the plugged in usb cables and or internal circuitry of my iMac by my mobile phones transmissions have been sufficient to wake up my mac...
     

Share This Page