My imac will not turn on

Discussion in 'iMac' started by Kelly1987, Aug 5, 2014.

  1. Kelly1987 macrumors newbie

    Joined:
    Aug 5, 2014
    #1
    Hi my name is Kelly.

    I have a imac since at least 2007. I am not sure the year. All I know is I turn it on and it goes to the apple symbol the is has some loading oval symbol then it turns itself off. It never goes to the screen with the icons. I inserted a picture to show what it does. A friend told me that is may need a new a/c power cord. I was wondering if anyone has any idea how to fix it or if it's just done for.

    Thanks for your time,

    Kelly
     

    Attached Files:

  2. Tomorrow macrumors 604

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
    #2
    If you're consistently getting to that point in the startup process, I can't see how the power cord could possibly be the problem.

    Have you tried resetting the PRAM?
     
  3. Kelly1987 thread starter macrumors newbie

    Joined:
    Aug 5, 2014
  4. Kelly1987 thread starter macrumors newbie

    Joined:
    Aug 5, 2014
    #4
    I just tried that. I looked up what it is and how to do it. It didn't work. :confused: Thanks for the advice tho. :)
     
  5. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #6
    Do you have an external clone? If so, try booting the clone (hold option when powering) and use disk utility to repair if possible.

    Same with any system DVD that matches your Mac.
     

Share This Page