My iOS 5 GM upgrade experience.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wezman2k, Oct 9, 2011.

  1. wezman2k, Oct 9, 2011
    Last edited: Oct 9, 2011

    wezman2k macrumors newbie

    Joined:
    Aug 13, 2007
    #1
    i can say things didn't go well for me. made a backup with itunes 10.4.1 and 4.2.10 just prior to installing iTunes 10.5 beta 9 and ios 5. well, i restored to ios 5 and everything went well until i tried to restore from backup.

    initially i kept getting a message that said my backup is corrupt or not compatible with the iphone. i then tried restoring from an older iphone backup located from time machine to see if that worked. it didn't.

    eventually i just brought my backup to my friends computer which had 10.4.1. i put the phone in dfu and restored down to 4.2.10 which worked fine. when i tried restoring from the backup at this point the iphone would just disconnect for no reason in the middle of the upgrade. bummer.

    thankfully i didn't lose too much because it's all on my computer...i did, however, lose my app organization and settings, text messages etc.

    i won't be trying to upgrade early in the future, that's for sure. i'm also not sure if i really trust iphone backups anymore. now that i have everything back to normal i've made a fresh backup. let's hope i can rely on it for future updates/restores.

    edit: aside from the above issues i've been using iOS 5 and it's working great.
     
  2. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #2
    I think you only really have the right to complain when your complaint doesn't contain the word beta.
     
  3. masonhogfan macrumors newbie

    Joined:
    Oct 9, 2011
    #3
    It's because you have jailbroken in the past. Go to /private/etc/hosts and open it in text edit. Put a "#" in front of the second to last line and save. Every thing will work from there
     
  4. wezman2k thread starter macrumors newbie

    Joined:
    Aug 13, 2007
    #4
    I'm not complaining I'm sharing an experience.

    I have never jailbroken before.
     
  5. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #5
    you obviously did something wrong because it worked fine here.
     
  6. wezman2k thread starter macrumors newbie

    Joined:
    Aug 13, 2007
    #6
    I've installed iOS 5 betas before with no issues... So I did something wrong because my backup somehow was corrupt? I think I layed out my steps pretty clearly, so saying I just did "something" wrong is a little ambiguous.

    If I did do something wrong I'll accept that but I really don't think I did.
     

Share This Page