My ipad2 can't connect to wifi at home-help!

Discussion in 'iPad' started by kim222, Mar 24, 2011.

  1. kim222 macrumors newbie

    Mar 23, 2011
    I finally got my new ipad2 yesterday,,,trying to connect to home wifi (verizon dsl) but it say 'can not connect to the network'. I tried many different ways,,,changed network names, WEP, no WEP, my laptop and my old itouch connects well according whatever the change I make with network with or without Secrity codes. My ipad detects the network name but doesn't get connected with or without security..took it work today it works fine here. Entered the password, boom. I guess it's more of my DSL modem setting, I log into the router website but nothing I can changed around. Please help if anyone has an idea. Thanks..
  2. mkruck macrumors regular


    Apr 30, 2008
    San Antonio, TX
    You may want to make sure that you (or someone else that uses your connection) didn't turn on MAC address filtering.
  3. kim222 thread starter macrumors newbie

    Mar 23, 2011
    Thank you

    Thank you for mentioning that. That could be it. I thought the same thing. But i made sure it's off a couple of times. ( i used to use it but not anymore). is 'disabling' not enough?i will definetly check that again when iget back home. Thanks for the comment!
  4. sealos macrumors regular

    May 12, 2008
    Same thing happened to me when we got my wife her iPad last Christmas. Wound up resetting the router and doing the setup again. Didn't mind at the time because we were doing MAC filtering at first and took the opportunity to switch to WEP.

    Have you updated the router to the latest version?

    Good luck.
  5. kim222 thread starter macrumors newbie

    Mar 23, 2011
    I'll reset the router if nothing changes, thank you!

    I'll reset the router if nothing changes, thank you!
    Last night I tried updating the router too but it said unavailable. I've had this old wireless westell box from verizon for a long time
  6. sealos macrumors regular

    May 12, 2008
    Sounds like it could be time to get a new router. The Westell probably isn't Wireless N, so you'll most likely see a big boost in speed if you replace it.

    FWIW... I have an Apple Airport Extreme and can't be happier.

    Good luck.
  7. kim222 thread starter macrumors newbie

    Mar 23, 2011
    new modem

    I've been using this wireless modem/router provided by verizon at first subscription for more than 5 years..(and since then there were a lot of different models came out mostly given out free for a year subscribers)

    It is so ODD that it can not take my ipad..
    (I can connect my ipad prob. to all the other modem/routers in the world but not this particular one - westell versalnk 619a-w32wxx6-)

    if I set the network secured and type the password it says' the password is incorrect"
    if it's unsecred, it says "can not connect to this network"
    I reset it to factory setting but the same thing happened.

    Finally I called the verizon and went through 3 different technicians (one of them was called 'premium' tech) repeating the 'standard' procedure over and over again. They first said they dont specialize in device like ipad x repeats, or telling me to go to apple and conversation went in circles.

    In short...after raising voice..:(
    They are sending me a replacement..after hearing me saying I've been a long time customer..(wish I was not)

    I hate any occasions that I have to call verizon and hope it doesn't happen again. Well I won't be using my ipad (with internet connections) this wknd/ until a new modem arrives.
  8. mtvalenz macrumors newbie

    Feb 4, 2011

    You are going to have to upgrade the firmware on the router. I had the exact same problem. Drove me nuts because every other laptop in the house could connect, except the ipad. As soon as I upgraded firmware, and rebooted router, it connected right up. Good luck!
  9. kim222 thread starter macrumors newbie

    Mar 23, 2011

    There was update button, clicked, but it said unavailable. Went the westell website, told to contact verizon, mentioned it to a vrzn tech, no comment no action repeating it is the ipad.

    Glad to find out somebody had the same problem tho!!!
  10. kim2272 macrumors regular


    Jul 23, 2010
    Sunshine State
    Same thing happened to me and I reset the router like previously stated and that fixed it. Btw, our screen names are 1 digit in difference! :eek:
  11. kim222 thread starter macrumors newbie

    Mar 23, 2011
    Writing from my ipad!!!!!

    Even though a replacement router is on the way, iwanted to give another try to this router and searched for firmware myself and in ten minutes i m on line!!!!!
    I just don't get how ignorant the knucklehead verizon tech agents( 'three' of them.. Including the so called 'premium tech') are (and so robotic!). i went through 3 different agents over 1- 1 1/2 hr.

    I'd like to leave a link where i got the new firmware just so that it can benefit people experiencing the same problem.

    I initially wanted kim2222,,, but got one key lazy :)
  12. drag0nz89 macrumors newbie

    Nov 27, 2012
    Thank you so so much

    Hey KIM 222

    i was experiencing the SAME EXACT ISSUE. i just got my brand new ipad3retinadisplay, and my sister got her windows8 laptop. both couldnt connect via wifi. about 1 hour of resetting and stuff.
    -finally went to google, FOUND YOUR THREAD.

    i followed your directions, and it worked. thanks so much.

    even though this was like 1.6 years ago for you. i just wanted to let you know you made a difference for me.

    saved me the call and long hold times with those geniuses at verizon.


    ---for anyone having the same issue similar to me, the only hint i'll have to suggest for someone like me (a noobie) is that when you download the .upg file, go onto the page and then find the page where you can upload that file. thats where the magic happens.:):):):):):):):):)

Share This Page