My iPhone 3G Problems

Discussion in 'iPhone' started by help!!!!!, Aug 27, 2008.

  1. help!!!!! macrumors member

    Joined:
    Mar 30, 2008
    #1
    I would just like to point out my frustration with my iPhone 3G. Just 5 minutes ago my iPhone froze while I was in MIM. I couldn't do anything so I turned it off and then back on and ALL my data was deleted, music, videos, pictures and apps. I am on my third replacement and I can't handle this anymore. At least once a day usually 2-3, it randomly goes to the startup screen. Then I have to force it into recovery mode and restore it and resumc all the data which takes about 4-5 houres. I am also having bad 3G in a area in Whig I should have excellent 3G. My web speed with 3G is 736.8 mb. From my perspective it is so much slower than EDGE.





    -Jonah
     
  2. greenmymac macrumors 6502a

    greenmymac

    Joined:
    Oct 25, 2007
    Location:
    Tulsa, Ok
    #2

    sorry join the club!
     
  3. weeman macrumors 6502

    Joined:
    May 6, 2007
    #3
    I have the same exact problem with my 1st gen..ive had to restore it at least 2-3 times every week since the buggy 2.0 firmware came out
     
  4. StoneColdSober macrumors 6502

    Joined:
    Jul 19, 2008
    #4
    I totally understand your other problems but this is not a bad speed and EDGE isn't capable of half this.
     
  5. help!!!!! thread starter macrumors member

    Joined:
    Mar 30, 2008
    #5
    I dont know if i have alredy said this but I am on my second replacement (3rd overall iPhone 3G) and I am bringing it in again tommorow night along with my MacBook Pro
     
  6. StoneColdSober macrumors 6502

    Joined:
    Jul 19, 2008
    #6
    I thought it was your third replacement? They may be able to help with some of your issues but as in my prior post, your data speeds don't seem out of line and they are definitely faster than EDGE.
     

Share This Page