My iphone 3G won't sync apps with iTunes 9.0.3 anymore :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by thomascasio, Feb 18, 2010.

  1. thomascasio macrumors newbie

    Feb 18, 2010
    Hi there!

    I have noticed that since last night I have not been able to sync apps or anything else from my iTunes (recently updated to 9.0.3) to my jailbroken iPhone (jailbreak done with blackra1n).

    Funny thing is that I don't remember changing any settings on the iphone or itunes, the only change I can recall is that I did the iTunes update to 9.0.3, can that be the source of the problem?

    It looks like the iTunes is sort of ignoring my request to sync apps, my apps are all on my iTunes page, iTunes recognize my iPhone normally when I plug it in but it just does not sync and no error message is displayed at all :(

    It reads syncing but it takes less that 6 seconds and it just stops as if the task was finished but it actually did not sync anything...

    Any help?

  2. Franzen Fanatic macrumors newbie

    Feb 20, 2010
    Gosh. This same thing is happening to me! It's the first time I've ever tried to transfer my apps to my computer and I have no idea what's going on. I just downloaded the new itunes and just figured out how to transfer everything, but when I do so, the same thing happens, it starts to transfer but stops after about two seconds. I don't have a mac computer and I'm really not good with itunes, but it's frustrating. Is it maybe a glitch with the new version of itunes? Since I have nothing backed up, I don't want to restore everything either. I feel so stupid because this should be so simple, but I don't know what to do..
  3. gravitas macrumors newbie

    May 5, 2010
    repeat of the same

    I am experiencing the same precise problem.

    10.6.3 OS X version and the latest iTunes 9.1.1 (12)

    Sync starts, then cancels itself after 2 seconds. No error messages.

    Also iPhoto doesn't see the device at all: I can't sync my photos.

    I have every type of content sync disabled from iTunes (backups only) and still it doesn't sync: so corrupted content cannot be the reason. Additionally the sync won't work with all content enabled either (in case you are wondering).

    Same USB cable syncs all of my various iPods to the computer all-ok without any trouble.

    Meanwhile internet tethering through the USB cable works all-ok, as does MobileMe sync. So this is definitely a software problem on the iTunes end.

    Reseting sync history through the iSync application does not work: after reset the same problem repeats.

    Restoring from backups is not an option as there are no backups for this iPhone (cannot be restored).

    Also booting any device, removing and re-attaching any cable does not fix the problem.

    .. there seems to be no fix for this. So far nobody has been able to help: Apple's tech support is clueless, as is the local carrier's tech support. All software and devices are legit versions purchased and pair for with proper licences - no jail braking. With all the latest software as well.

    Too difficult for our tech community to handle? So far it seems so..
  4. -aggie- macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
  5. OrangeCuse44 macrumors 65816


    Oct 25, 2006
    Long Island, NY
  6. AustinJJ macrumors newbie

    May 11, 2010
  7. OrangeCuse44 macrumors 65816


    Oct 25, 2006
    Long Island, NY
    Still cant sync anything, movies, shows, music, apps. Has anyone found a solution to this problem?
  8. hfhernandezf macrumors newbie

    May 15, 2010
    The same problem!! I've found a solution but i don't recommend it. Open itunes and plug your iphone. Then click your phone on the left side bar and click the applications tab, then uncheck "sync apps". As I wrote I don't recommend it, 'cause if you decide to do this, all your apps will be deleted. Click the ok button and wait while itunes delete all apps. Once have finished check "sync apps" again and re-install your apps.

    If someone find a better solution I'll be waiting!!!
  9. hfhernandezf macrumors newbie

    May 15, 2010
    Does anyone have installed "Infinidock" on your jb Iphones? Perhaps this is the problem.....
  10. divine975 macrumors newbie

    May 18, 2010
    Hi there,

    It seems that my problem has been partially resolved after following the steps mentioned in previous thread of "hfhernandezf".

    Now i am able to sync my Apps in itune ( with my iphone. But the Apps installed directly on my iphone are still not synchronizing in my itune.

    Any suggestion will be appreciated.
  11. someguy1963 Guest

    Jun 4, 2010
    think i just had same problem: couldnt sync apps to 3.1.3 redsn0w iphone 3g...
    not sure which of the things I did actually solved it but I basically just turned iphone off/on, logged into my itunes account on store and also authorized my computer again. when i plugged it back in all was working again
    hope this works :)
  12. bvrtulane macrumors newbie

    Jun 16, 2010
    Me too

    Same issue but with slightly different hardware. I have a PC running windows 7 pro 64bit and the 64bit version of itunes 9.1.1 (12). iPhone 3GS running 3.1.3 not jailbroken.

    The phone shows in iTunes but when I click "sync" the sync dialogue shows on the phone for 2 seconds then stops. No sync takes place. I restarted, reset, removed SIM card, reinstalled iTunes, reauthorized my computer, I even restored the iPhone to factory. No luck.

    Unless someone has a better tip I guess Ill either install iTunes 9.0 or wait for a new iTunes when the iPhone 4.0 launches in a week. Any help?
  13. rhett7660 macrumors G4


    Jan 9, 2008
    Sunny, Southern California
    Same issue here, but mine started after I upgraded to 10.6.4. All of my music etc were erased and it is saying I must restore my iPhone to original state. My phone is JB using Blackrain. I have tried to load new material on the phone but the phone is not recognizing anything I put on it. It will show up on iTunes but not on my phone.

    Don't want to unJB my phone but it looks like I might have to.
  14. capercat macrumors newbie

    Oct 23, 2011
    I'm having the same problem. Did anyone found a solution or a fix yet? Desperately needs help :(
  15. NevMac macrumors newbie

    Dec 31, 2011
    -Connect your iPhone with the USB cable to the computer you typically synch with.
    -Open iTunes.
    -In iTunes, on the left sidebar under 'Devices' click on your iPhone name.
    -On the top bar, click on 'Apps'.
    -Check the boxes for all the apps you want to move to your iPhone from iTunes.
    -At the bottom right side, click on 'Sync'

    The apps you've selected in iTunes will start uploading to your iPhone.

    You can follow the same steps to transfer your music, photo's, movies etc. by clicking music, movies, photo's, videos etc. on the top bar in iTunes.

    Best of luck!
  16. tomtom12345 macrumors newbie

    Dec 31, 2011
    I faced the same problem,but funny thing is,it fixed up automatically!:D
  17. Cirrus11 macrumors newbie

    Jan 10, 2012
    Personally, every one I know is having problems with 3g iphone. do you think they rather us spend more money to upgrade... hmmm *wonders*

    I still cannot get my 3g iphone to work well, or sync up with either one of my computers (windows unfortunately) last month lost all my contacts trying and apps. Too bad for me! :(
  18. lolly.plop23 macrumors newbie

    Jan 22, 2012

    My 3G will sync music etc, but I keep getting this message at the end:

    iTunes cannot sync apps to the iPhone “lolly.plop’s iPhone” because the apps installed on the iPhone could not be determined.

    My phone software is up to date and I'm running iTunes 10.5.3 (3) on my Mac.

    Would love to know what's up.
  19. mad0o macrumors newbie

    Jul 30, 2012
    solved i think

    well, my 3GS didn't sync apps or anything, try to check if the credentials are missing. simply click Store > Sign in, enter your apple ID and password, and it's solved :) .. worked with me :)

Share This Page