My iphone 3gs runs VERY SLOWLY on my DLink Wireless router.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wants2tryMac, Dec 30, 2009.

  1. wants2tryMac macrumors newbie

    Joined:
    Jul 12, 2009
    #1
    hi guys,
    i just recently got my new iphone 3gs, but it runs very slooooowly on wi-fi connected to my D Link wireless router (802.11g/2.4Ghz).
    however, it runs pretty fast (streaming youtube videos) when i connect to my friends router, which is not the same as mine.:mad:
    i reset the network settings for the iphone, used a manual IP address, reset the router, but all didn't change anything.
    however, i noticed that within the instant i connect the wi-fi, it runs fast for a few seconds, and then just literally stops!
    before i think of buying a new router, does anyone know if i'm leaving something out? or is it a hardware problem with the iphone? anyone experienced the same issue? or anyone with any help to make it faster? is it possible?
    any help will be appreciated.
    thanks so much :)
     
  2. g2tegg macrumors member

    Joined:
    Sep 5, 2008
    #2
    First of all, why are you using a static IP address on your phone? If you reset your router it will by default be DHCP. Obviously your going to run into problems.
    My suggestions is reset the router back to default (press and hold the reset button on the back for around 10 seconds. You will see the lights on the front flash). Next, make sure your iPhone is set to default when it connects to the router. Your better off selecting the option to "forget this network" and re-connect throught the default settings.
    If you set up a IP address manually on your phone (which is called Static), without configuring your router IT WILL NOT WORK.
    What your could also do install from the App Store Speedtest.net app. Its free and you can see how fast your network is.
     
  3. wants2tryMac thread starter macrumors newbie

    Joined:
    Jul 12, 2009
    #3
    Thank you so much for your reply. I appreciate it.
    But I'm not using the static IP address on the iphone anymore. Also this may sound stupid (I'm not so tech-savvy :)), but if I reset the router, do I have to put in the username & password again? (I ask cuz my flatmate has the username/password from the ISP and he's on holidays). Thanks.
    Hope you reply soon.
     
  4. fullmanfullninj macrumors regular

    Joined:
    Dec 30, 2009
    #4
    You haven't mentioned, but how is the speed with your Macbook Pro (based off your sig)?

    If the speed is pretty slow on there too, it might not be the iPhone's problem. Haha, sorry to ask man, but who knows eh :p
     
  5. wants2tryMac thread starter macrumors newbie

    Joined:
    Jul 12, 2009
    #5
    No, the computer's speed works perfect, it's just the iphone :(
     
  6. wants2tryMac thread starter macrumors newbie

    Joined:
    Jul 12, 2009
    #6
    OK, I just quickly reset the router and even the iphone network settings. But it's still slooooooow :(
    Oh dear!
     

Share This Page