My iPhone 4 camera died?

Discussion in 'iPhone' started by atico5007, Feb 17, 2011.

  1. atico5007 macrumors newbie

    Joined:
    Jul 31, 2010
    #1
    Hi guys, I was having nice time on vacations , taking good pictures last night turned on camera to shoot a picture and all went he'll.
    Not a scratch on my phone, nothing.
    Now pictures are all green or cartoonish like images.
    http://img684.imageshack.us/i/imagekqq.jpg/
    This is how picture looks now!
    Please help! I'm in a bad reception place near mountains, and just posting using iPhone 4.
    And please excuse me for my bad english!
    Also new on posting images and that...
    Thank you!
    What should I do?
     
  2. chrishemley823 macrumors newbie

    Joined:
    Feb 16, 2011
    #2
    Just curious, how long have you been speaking English formally? Not just "How are you" and "Hello" but constructing actual sentences? I'm learning a new language at the moment and I want to know how people felt/feel when learning English.

    Anyway, that's definitely a faulty camera. Bring it to the Apple Store to get a new one.
     
  3. patp Guest

    Joined:
    Apr 10, 2008
    #3
    are you sure you don't have any camera apps open that add picture effects like this?
     
  4. gigapocket1 macrumors 6502a

    Joined:
    Mar 15, 2009
    #4
    Yeah.. that is just weird... are u using the stockk image app??? do u use other images app?? try closing all the apps in the multitask pan
     
  5. atico5007 thread starter macrumors newbie

    Joined:
    Jul 31, 2010
    #5
    Hi! Thanks to respond!
    I do have pro camera and night camera apps, however I made sure they were off. For my pictures right now I only used the "stock" camera app an a couple of pictures with HDR on but a small percent.
    I revolted the phone, deserted all settings , home and power button till apple's logo came in and all sort of things but camera still bad.

    To chrishemley... Well, my English is from when I was 7 years old, I lived 2 years in Ontario, Canada. An awesome place to my memory! I'm 45 right now
    But I try to exercise reading all my Internet stuff in english.

    I hope you can understand me anyways ;)
    Been reading this forum for more than two years but only posted two times, well tree with tis one...
    Owner of iPhone 3G 8GB, 3Gs 32 GB and my beauty iPhone 4 32 GB black.
    Never, ever had a problem with anyone of tree except for this camera problem.
    I'm in Cordoba, Argentina , in vacations . A place where rivers and mountains are beautiful but 3G signal is almost unreachable(?)
    If I dial *3001#12345#* it returns me -112 dB! But still can reach emails and som forum reading ! Also managed to upload to imageshak and all .
    I'm shocked! No other camera at hand this good and got 7 more days left on vacation !

    Cheers to all!
     
  6. jacollins macrumors 6502a

    Joined:
    Jun 19, 2010
    #6
    You shut down and restarted the phone yet? Hold down the home button and the sleep button at the top until you get the screen asking you to slide to shut down. Slide that, then wait a bit, then press the Sleep button to power it back up.
     
  7. atico5007 thread starter macrumors newbie

    Joined:
    Jul 31, 2010
    #7
    Yes I did that but nothing happened. As I wrote before, tried lots of tricks to no avail ( damn autocorrect on my previous post)
    Thanks
     
  8. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #8
    If you can, try restoring your phone via iTunes. If that doesn't work, it may likely be a hardware malfunction.
    You may be stuck until you return from vacation.
     

Share This Page