My iPhone 4 charger is acting weird

Discussion in 'iPhone Accessories' started by ABCDEFGHIJKLMAO, Sep 8, 2011.

  1. ABCDEFGHIJKLMAO macrumors member

    Aug 5, 2011
    New Jersey
    I have been using my iphone 4 home charger from day 1, and lately its been acting weird when i plug in my phone.
    It says that it cannot charge my iphone because it is unsupported device:mad
    It shows me ! With triangle on the screen!
    Both my phone and charger is original product, and i dont know why its doing that. Is there problem with my phone or the charger??
  2. steve knight macrumors 68020

    steve knight

    Jan 28, 2009
    more of a chance it is your phone. or fuzz in the jack clean all of the lint out and see if it helps. though we got a phone replacement that gave that error sometimes then after awhile with every charger or plug.
  3. ryanaaaah macrumors newbie

    Aug 24, 2011
    it may probably the battery or the slot problem. but try another charger first
  4. mpossoff macrumors 68020

    Mar 21, 2010
    I get that message with my car charger sometimes.
  5. ABCDEFGHIJKLMAO thread starter macrumors member

    Aug 5, 2011
    New Jersey
    still gives me the same message.....:mad::mad:
    guess i will have to take my charger and phone to apple store for warranty.
  6. LTMK macrumors member

    Apr 1, 2011
    NY, NY
    the chip inside your plug maybe damanged .... you need a new one ...sorry
  7. MacBpro macrumors member

    Mar 30, 2011
    Chicago, IL
    agree ... even its original phone charger... it will break... sorry you need a new one
  8. MacNewbie03 macrumors regular


    Jul 3, 2007
    Hicksville, OH (Northwest Ohio)
    My AT&T car charger also makes this message appear on my phone. It used to work fine but here lately it doesn't. I got the charger when I ordered my phone in August 2010, I wonder if there is differnce between the iPhone 3 and the 4 as far as power draw? The phone charges fine when using the Apple wall charger or using my Mac to charge it.
  9. jekyoo macrumors 6502

    Sep 11, 2007
    had the same issue with my charger. i just went to apple and got it replaced under warranty, fixed the problem.

Share This Page