My iPhone 5 home and power button won't work at all!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chewy48, Jun 12, 2013.

  1. chewy48 macrumors newbie

    Joined:
    Oct 12, 2009
    #1
    Hey everyone! Well here's my situation. Yesterday I was bored and I was playing with my iPhone 5. My iPhone has always had this problem where the screen is loose when you press it. So yesterday I had time to spare and I decided to see if I could fix it by opening it up. By the way I also have experience with iPhones I've done a lot harder things like installing led mods on iPhones and replacing screens on iPhone 4 and iPhone 4S. Anyway I just decided to take the screen of which was 1000x easier than the iPhone 4 and I also disconnected the battery and took off those 2 black little flex cables located under the emi shield and battery shield. I then put everything back together which I thought was no problem but apparently something must of went wrong. After I put everything back together I tried turning my iPhone on and it wouldn't turn on! I was freaking out and I took it apart again and double checked that all the cables were connected and they were. It then came to me that maybe the power button isn't working so I plugged in the charger and what do you know! It turned on! I was relieved but still confused as to why the power button wasn't working. When my iPhone got to the home screen I unlocked it and that's when I noticed that my home button wasn't working too! I was and still am pissed haha. I tried recalibrating the home button with assistive touch but that still didn't work. So my last resort was restoring and losing my jailbreak because I thought that maybe it's a software error. But after a restore I had the same problem so I now know its something hardware related. Can someone please help me find out what the problem is. It's annoying having to plug my phone into the charger just to turn the screen on! I know that the home button has contact with the gold contacts so its probably not that. I was thinking that maybe the oil from my hands possibly got onto some components possibly those 2 flex cables I mentioned above but then again I don't know if those have anything to do with the power button or home button at all. I was also thinking about taking out the logic board and cleaning it with alcohol but I don't know if that would do anything because I don't see any corrosion. So anyways I would really appreciate it if someone can help me find out what the problem is! Please give me your input and stuff thanks!
     
  2. MrMacMack macrumors 6502a

    Joined:
    Oct 24, 2012
    #2
    Open it back up and inspect again. You did that already once before and discovered a problem so do it again.
     

Share This Page