My iPhone 6 Plus is stuck on EDGE (E) data SOMEBODY HELP PLEASE

Discussion in 'iPhone' started by jerome19961996, Nov 4, 2014.

  1. jerome19961996 macrumors newbie

    Joined:
    Apr 22, 2012
    #1
    SOMEBODY HELP PLEASE :( my iPhone 6 Plus is stuck on edge on the Telstra network
    i purchased an iPhone 6 Plus 128gb a few weeks ago from apple and when i received it i restored through iTunes (Latest version) the old backup of my iPhone 5 32gb (which was running ios 7).. after backup had completed my iPhone 6 is now stuck on EDGE Data!!and when im in the city i get 4g sometimes but i cant live without 3g data.. i usually get 3g all the time.. i tried resetting network settings, and all settings, hard reset, reboot without sim installed. and nothing helped, so i decided too restore the iPhone too factory settings (ios 8.1) and the problem was fixed !! so i now know there is something wrong with my backup, but i can not have my iPhone without all my past messages/photos.. so i then tried fixing the issue by restoring the backup back onto the iPhone 6 and backing up through icloud .. i purchased 200gb icloud data and i backed it up.. it tool about 3 days..once backup was complete i restored the iPhone too factory setting once again and restored my icloud backup,, AND STILL THE PROBLEM PERSISTS@!!!!!!!!! is there something i can do too modify the backup or settings or something and fix the backup? its like its corrupted or something. it is also now jailbroken could there be a tweak or something that could fix it?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Did you contact the carrier or where you purchased the iPhone?

    Maybe its defective.
     
  3. p3ntyne macrumors 6502

    p3ntyne

    Joined:
    Jan 10, 2014
    Location:
    Sydney, Australia
    #3
    I would contact Telstra. The support number is 132200 BTW.

    Perhaps you could try removing the SIM card and inserting it again...
     
  4. jpc0480, Nov 4, 2014
    Last edited: Nov 4, 2014

    jpc0480 macrumors newbie

    Joined:
    Nov 4, 2014
    Location:
    Amsterdam
    #4
    I would restore it and go back to the shop. I had something similar happen to my 5S once before. I was flying and when I landed and took it out of airplane mode it would not connect to anything higher than GPRS and where I live there is usually always 4G and if not then 3G. I turned the phone off for some minutes and then powered back on and all was well. Not sure what the cause was though? I tried a respring and tried turning airplane on/off and still would not come back to 3/4G. After a reboot it came right back on.
     
  5. jerome19961996 thread starter macrumors newbie

    Joined:
    Apr 22, 2012
    #5
    no it is not a telstra problem as i already tried the same sim in multiple phones including mine // when i restored the phone there was no problems

    ----------

    i purchases it outright from apple and there is nothing wrong with the phone because the problem goes away when i restore factory settings through itunes
     

Share This Page