My iPhone now syncing to two computers, how can I only keep one?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by bearcolin, Mar 25, 2012.

  1. bearcolin, Mar 25, 2012
    Last edited: Mar 25, 2012

    bearcolin macrumors newbie

    Joined:
    Mar 25, 2012
    #1
    I got an iMac first, let me call that iMac "A", and I used to sync my iPhone to A. Then I got a Macbook, let me call that Macbook "B". When I use B for the first time, I used Migration Assistant to transport all the files and settings from A.

    After that, when I use A and B in the same Wi-Fi network, both of their iTunes shows my iPhone on their list. And I can sync my iPhone to both A and B without the warning window showed up. But, I can't manage both two iTunes library at the same time, so I want to choose only B to sync my iPhone. And I found out that, in fact, when I turn on the Wi-Fi sync option, my iPhone always trying to sync with A, not B. Now I can only use cable to sync my iPhone with B, and that's not over, I found sometimes all of my apps are selected when I tried to sync my iPhone with B, no matter how many times I changed that setting, the next time all the apps will come back to be selected again! I think that's A bothering B...

    How can let my iPhone forget A and only accept B?
     
  2. TheAppleSource macrumors regular

    TheAppleSource

    Joined:
    Mar 9, 2012
    Location:
    United Kingdom
    #2
    When your iPhone appears in the sidebar of iTunes on A, if you click on it and then get the sync options appear, try un-ticking the boxes the things you don't want to sync (potentially all of them).

    Also, if it's trying to sync automatically, you can go into Preferences, then Devices, and then tick the "Prevent devices from automatically syncing with iTunes" box.
     
  3. bearcolin thread starter macrumors newbie

    Joined:
    Mar 25, 2012
    #3
    Thank you!

    But at last, I just format my iPhone. Because I had deleted all apps on A, if I changed sync settings I have to copy all apps from iPhone to A, so I give up...

    After format my iPhone, I used cable to connect with A as an new iPhone, synced. Then, format it again, and connect to B, and restored from backup.
    Now, with Wi-Fi sync turned on, my iPhone won't appear on A again. I'll wait and see if someday it will come back again. Thank you!
     
  4. bearcolin thread starter macrumors newbie

    Joined:
    Mar 25, 2012
    #4
    NO...
    Today, I want to use my iMac to charge my iphone, so I connect my iPhone with my iMac using the cable. Then iMac recognized my iPhone as the past... as it has never been format... so I believe this A will still bothering B in the future...

    I just want a solution that will let my iPhone forget A's iTunes library, or let A's iTunes library forget this iPhone...
     
  5. TheAppleSource macrumors regular

    TheAppleSource

    Joined:
    Mar 9, 2012
    Location:
    United Kingdom
    #5
    If you go into Preferences and then Devices, are there any backups there? Specifically for your iPhone? If so, you could delete them (provided you have backups on your MacBook).

    Moreover, with your device connected to the iMac, when you click on the iPhone in the sidebar (which should take you to the "main" iPhone options tab), what options are ticked at the bottom?
     
  6. bearcolin thread starter macrumors newbie

    Joined:
    Mar 25, 2012
    #6
    Thank you.

    I had delete the mobile backup folder of iTunes already.

    When I connect iPhone with iMac (actually, if they are in the same network, they now connected automatically, because I've enable the Wi-Fi sync option on iPhone) only sync through Wi-Fi option was ticked.
     
  7. cpgneinc, Jan 29, 2013
    Last edited: Jan 29, 2013

    cpgneinc macrumors newbie

    Joined:
    Jan 16, 2010
    #7
    Syncing to two Macs, want just one

    From what I remember, you can choose to authorize or de-authorize the computer for a particular device. If you have set up the second machine you own with the same user name, go into your original machine, and there may be a way to de-authorize the computer for your iPhone. Look under top menu column 'advanced' and 'store', with store not being blocked with parental controls. I had this option on iTunes 10 on my PPC. There is also an option to prevent automatic syncing by ticking a little check box in preferences (certainly this is the way Apple treats iPods, maybe iPhones, too). This may be all you have to do to fix your problem. If you manage to de-authorize machine A, afterwards you will only be able to use your machine B for syncing, etc. Mac A may not recognize the device at all and ask to initialize it. Search the web or check at the Apple website about authorizing a Mac, there are help files there. Also, remember with a device they may only allow you so many authorizations. If you ever sell your machine or decide to trash it, don't forget to de-authorize it, as it communicates this back to the Apple server, and you get that authorization credit back to use on another Mac. I think the max number is five.
     

Share This Page