My iPhone wont charge, need help troubleshooting.

Discussion in 'iPhone' started by stateofmind, Jan 14, 2008.

  1. stateofmind macrumors regular

    Joined:
    Nov 29, 2007
    #1
    Ok, so I put my iPhone in its charging dock last night and check this morning and it did not charge at all, still in the red battery stage.

    I then tried charging with no dock, no go. Tried charging on laptop, nope. Although I only left it with no dock and on the laptop for only about an hour.

    I thing I notice is when I connect my iphone, the battery in the top right has a silhouette of a plug. Is this what its supposed to be? I thought it maybe the symbol that looks like lightning (sorry if that description is vague :eek:)


    Any help?
     
  2. stateofmind thread starter macrumors regular

    Joined:
    Nov 29, 2007
    #2
    Sorry, my connection is slow, and I mistakley posted twice
     
  3. Telp macrumors 68040

    Telp

    Joined:
    Feb 6, 2007
    #3
    Does the phone mount? If so, restore it through itunes, and see if that helps. If that doesnt help, i would bring it to apple and get it replaced.
     
  4. Aniej macrumors 68000

    Aniej

    Joined:
    Oct 17, 2006
    #4
    the lightening/plug symbol is exactly what you want to see when you have the iPhone connected in order for it to be charging. Like the previous post I recommend doing a full restore, however I have a suggestion to add before that. Make sure the iPhone is actually on when you are charging it, do not plug it in and then power off. I am not sure if this is something that was fixed with the firmware updates, but in the past when I have tried to charge mine with the devise powered off it did not charge.
     
  5. hypnometal macrumors newbie

    Joined:
    Feb 20, 2007
    #5
    One other thing. Is your iPhone overheated? I had a similar problem today, and when I downloaded the user manual, it said that if the iPhone is too hot, it affects the charging(I think laying it on my pillow when my bed is two feet from the radiator might have been a mistake. ;-) ) Once I plugged it into my phone, synced it with my laptop, and now it's charging with its usual speed. :)

    I don't know if that helps you avoid an unnecessary reset. If nothing else, download the manual from http://www.apple.com/support/manuals/iphone or try http://help.apple.com/iphone for some answers.
     
  6. sergiuria macrumors 6502a

    sergiuria

    Joined:
    Oct 21, 2008
    Location:
    Near a bunch of T-Rex
    #6
    I hope the OP resolved this issue before your post :p
     

Share This Page