My iPod Classic 2nd Generation doesn't sync with iTunes

Discussion in 'iPod' started by FaxingMars, Mar 16, 2013.

  1. FaxingMars macrumors newbie

    Mar 16, 2013
    Hi, I bought a powermac G5 to sync my ipod classic 2nd generation, 20gb (from 2002) over firewire, however when I plug the ipod in, it charges but iTunes does not pick it up. I tried downloading earlier versions of iTunes but it still doesn't see it. I also tried putting it into disk mode and then into the computer, but it still says 'OK to disconnect', and not 'Do not disconnect' as it should.

    When I got onto 'about this mac' and then firewire devices it says it is unable to list firewire devices (in red writing -error?). Is there anything I can do to fix this? Thanks
  2. Fralle macrumors 6502


    May 18, 2012
    South part of North
    Obviously there is something wrong with the firewire on the G5. I don't think its the cable, but you could change to another FW-cable just to be sure. You could also try and find another computer with firewire to make sure its not the iPod. The latest iTunes software sync with all iPods even the first generation ;)

    I'm sorry I can't help you with any solution on the FW problem in the G5...

Share This Page