My iPod's volume bar and all volume control is gone unless I have headphones in.

Discussion in 'iPod touch' started by pretty, May 20, 2011.

  1. pretty macrumors newbie

    Joined:
    May 20, 2011
    #1
    I have an iPod touch 2nd generation.
    I have it to the most recent update (4.2.1)
    I have iTunes updated, I tried resetting, restarting, and restoring (restoring it was a bunch of difficulty.) my iPod.
    But one day I was listening to a song on my iPod and wanted to let my mom hear it, so I pulled the headphones out and my iPod went mute, so I tried turning it up with the side volume thing and it didn't work, so I went to the music thing and the volume bar was not there, I went into settings to see if I did something there. Nothing.
    What is wrong with my iPod?


    My warranty is up, so I can't send it in.

    (I asked this on yahoo and I only got one crap answer, so.)
    THANKS.
     
  2. Mr Slippy IV macrumors 6502

    Mr Slippy IV

    Joined:
    Feb 24, 2010
    Location:
    Vail, AZ
    #2
    Your iPod is behaving as if it's plugged into a dock. If you have a dock, try playing music through the dock or at least connecting it and then disconnect it. Do this many (around ten) times and then repeat the process with your headphones. Hopefully, this should work.
     
  3. RafaelT macrumors 65816

    RafaelT

    Joined:
    Jun 9, 2010
    Location:
    Lakeland, FL
    #3
    Also make sure the 30 pin connector is clean. Not likely but it is possible that you got some gunk on there and it thinks its on a dock.
     

Share This Page