My Itunes won't play the video, only the videos audio?? black screen??

Discussion in 'macOS' started by cootersgarage6, Jan 15, 2011.

  1. cootersgarage6, Jan 15, 2011
    Last edited by a moderator: Jul 25, 2011

    Joined:
    Nov 6, 2010
    #1
    This is my second post with my problems with Itunes today, but it's ANOTHERRRRRRRRRRR stupid problem. (Starting to hate apple now, like I said, they are getting difficult and hard to use)
    When I go to play a video on my itunes library on my mac, it just shows a blank screen and then the audio still plays. This happens to all my videos.... how do i fix this??

    Thanks!
     
  2. srgdavis macrumors newbie

    Joined:
    Jan 18, 2011
    Location:
    Wolverhampton, UK
    #2
    iTunes black screen...

    I've got the same issue! Only started today mind. It was intermittent to start with but now all purchased films, TV shows etc will only play audio.

    Very strange?! The children need Peppa Pig... not sure how much longer I can hold out...:(
     
  3. srgdavis macrumors newbie

    Joined:
    Jan 18, 2011
    Location:
    Wolverhampton, UK
    #3
    iTunes black screen

    This doesn't effect only purchased items - it's all video content through iTunes. The same stuff works with Preview or directly through Quicktime though??
     
  4. khan1701 macrumors newbie

    Joined:
    Jan 22, 2011
    #4
    same problem

    Same problem here that just started this week. If I switch the playback setting to play in an external window it will display the video. But only for one, the next video in the playlist is a black screen again. Switching back to playing within the iTunes window again fixes it for one video only.
     

Share This Page