My iWeb site doesn't have www. before it, and I cannot figure out why..

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by AdventurousJosh, Jan 26, 2009.

  1. AdventurousJosh macrumors 6502

    Joined:
    Aug 11, 2008
    #1
    Hey guys,
    I hosted a website in Godaddy awhile back, www.example-akwoods.com.
    But for some reason once I set up godaddy and Iweb's forwarding, I can only get to the site by typing in "example-akwoods.com. You see, if I type in www.example-akwoods.com it doesn't work. Nothing comes up, page not found. I have to drop the www. and it drives me crazy! when signing up for godaddy, when it asked for the websites name, was I suppose to add in the "www."? It had the .com already there so I assumed it just needed the website title..that it would add the "www." by itself.

    I can't figure it out!


    Thanks...
     
  2. DLH macrumors member

    Joined:
    Jun 27, 2006
    #2
    Website addresses do not have the "@" character in them. That's only used for e-mail addresses.

    Why are you trying to use "example" in the website address?

    This is typical: http://www.akwoods.com/ and seems to work correctly.
     
  3. AdventurousJosh thread starter macrumors 6502

    Joined:
    Aug 11, 2008
    #3
    Sorry, I didn't mean to include "@", just giving example. btw, I had no idea akwoods was even a site!
    Okay, my website is akjosh.com
    I cannot get to my site by typing in www.akjosh.com - only akjosh.com.

    See what I mean?
     
  4. Ninja Guidan macrumors regular

    Joined:
    Sep 30, 2005
  5. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #5
    In you DNS Settings for your domain "akjosh.com" I believe you need to add the Host Name "www". Check with whoever hosts your Domain Name.
     
  6. DLH macrumors member

    Joined:
    Jun 27, 2006
    #6
    Yes. It's a DNS problem.

    akjosh.com resolves to an IP address and www.akjosh.com does not.

    The easiest thing to do is add a "CNAME" record in the DNS manager at GoDaddy which points www.akjosh.com to akjosh.com.

    I don't host sites with GD, so I can't give specifics on that. Have a look here: http://help.godaddy.com/article/681

    Edit: Too slow!
     
  7. bzboy01 macrumors newbie

    Joined:
    Jan 26, 2008
    #7
    same problem with godaddy

    I am having the same problem. When I enter www before my website, it starts asking me about my username and password and when I enter just mydomainname.net it start working. Can someone help me understand this?
     
  8. ivnds macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #8
    Is it possible to have both settings working? I have the opposite problem:

    When trying : mysite.com
    A "domain is parked in godaddy.com" landing site appears.

    But when i try: www.mysite.com
    it properly loads my site. Id prefer without the www since people tend to ignore it nowadays.
     
  9. IgnatiusTheKing macrumors 68040

    IgnatiusTheKing

    Joined:
    Nov 17, 2007
    Location:
    das Fort
    #9
    Go to the "Total DNS Control" part of your GoDaddy account and add a CNAME for "www" that points to web.me.com.
     

    Attached Files:

  10. annapolisjohn macrumors newbie

    Joined:
    Feb 22, 2009
    #10
    Reset Safari and try again.
     
  11. ivnds macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #11
    No Go. I don't think this is a browser issue, unfortunately it happens both in Safari and Firefox.
     
  12. IgnatiusTheKing macrumors 68040

    IgnatiusTheKing

    Joined:
    Nov 17, 2007
    Location:
    das Fort
    #12
    On the same "Total DNS Control" page I referenced above, try creating a CNAME for mysite.com and pointing it to web.me.com. Having both those CNAMES worked to make my site available on both the "www.mysite.com" and "mysite.com".
     
  13. ivnds macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #13
    Thanks a lot! It works now, I was a bit frustrated because at first it didn't seem to, but I just had to wait a bit.
     

Share This Page