My jailbroken iphone doesnt receive calls

Discussion in 'Jailbreaks and iOS Hacks' started by Apple Berry, Jan 18, 2010.

  1. Apple Berry macrumors newbie

    Joined:
    Jan 18, 2010
    #1
    Hi. I jailbroken my iphone with "Blackra1n" and used with T-mobile sim card. Everything else works fine but I cant receive any calls and text messages when I dont use the phone.(I mean, when the phone is "stand by") My OS is 3.1.2 and my computer is windows. I know that some other people also have same problem as me, and I already looked up many websites but I couldnt find any solution. Could anyone please kindly tell me any solution to solve this problem?? I cant use this phone since it doesnt receive calls. TT
     
  2. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #2
    If I were you I would try again. Restore your phone, set up as new, and re jailbreak + unlock.
     
  3. RangerXML macrumors regular

    Joined:
    Jul 4, 2009
    #3
    Seems to be something with blacksn0w, you can get calls reliably if you turn 3G off in settings>>general>>network. If you restore to new, or even to a back up, it makes no difference, it will work for a while and then act up again. Your phone may also experience random freezes, lock-ups and reboots. All we can do is wait for a better unlock solution and it looks like OS 4.0 will be here before that.
     
  4. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #4
    That reminds me. Make sure you have 3G off when jailbreaking.
     
  5. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #5
    You mean when unlocking.

    You should only need to do so also if you are using a 3G SIM from another provider whose 3G service isn't being transmitted on a band that is supported by the iPhone's radio chipset (for example, T-Mobile U.S.).

    -- Nathan
     
  6. RangerXML macrumors regular

    Joined:
    Jul 4, 2009
    #6
    Meh, I have nothing to loose. Might as well restore my phone to new and jb and unlock with 3G off see if that changes anything. The 3G bug with blacksn0w sucks beyond all.
     

Share This Page