My Jailbroken iphone won't restore.

Discussion in 'Jailbreaks and iOS Hacks' started by tyranical, Feb 19, 2010.

  1. tyranical macrumors regular

    Joined:
    Jun 12, 2009
    #1
    Its a 3GS, currently on 3.0 and jailbroken with redsn0w.

    I Jailbroke it ages ago and want to restore it and re-jailbreak to start fresh, i intended to jailbreak it onto 3.1.2

    So i downloaded the 3.1.2 IPSW and tried to restore it with that using the shift - restore method in itunes, it doesn't work though it says my device is not eligible for this update.

    I then tried doing it with the 3.0 IPSW as i assumed that one would work since its already on 3.0, that won't work either, same error message!

    What do i do? =/
     
  2. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #2
    use the search function and look at any of the other 100 posts on the subject
     
  3. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #3
    Short answer...

    When Apple releases updates they discontinue the ability to restore to older versions... If you have a 3Gs.

    That's why when you're jailbroken you need to hit the Make My Life Easier button in Cydia. Then you can still downgrade or sidegrade or whatever.
     

Share This Page