My late 2008 MacBook Pro that I'm trying to upgrade still causing massive problems. Help please!

Discussion in 'MacBook Pro' started by wavymedia, Dec 12, 2015.

  1. wavymedia macrumors newbie

    Joined:
    Oct 16, 2015
    #1
    Hello everyone,

    So I have been upgrading my late 2008 macbook pro for a while now, after having problems with hardware that I have had to return, ram updates making my computer slower, new SSD drives lowing it down even more (or at least it seemed). It has taken so long that I can’t even remember how I solved the previous problems.

    I removed the broken optical drive and replaced is with a Samsung 850 EVO SSD drive in a caddy. I added 8gb of RAM which turned out to be faulty, so that was replaced with 8gb of corsair RAM (definately correct specs, and recognized as 8gb). I copied the system onto the SSD and fromatted the HDD and the syste boots off the SSD.

    Different problems have come and gone, but where I now?

    on startup, initially running well, but after 10 minutes MASSIVE slowdown in performance to the point of becoming almost completely unusable, especially after trying to view video content. Text input lags massively on any application.

    I used blackmagic disk speed test and I got:

    WRITE SPEED - 160MB/S - 200MB/S
    READ SPEED - 240MB/S - 250MB/S

    Right now what I want to do is format both the disks and fresh install from USB. So I got El Capitan on a USB (really wanted to just install mavericks again, but just downloading the latest OS seemed easier).

    When I restart the mac with the option key and choose to boot from the USB the apple log appears with a loading bar. The bar takes about 2 hours to fill and then refuses to proceed, just showing a full bar for at least 4 hours before I gave up. This has happened every time I have tried.



    When I install El Capitan in finder and the restart computer to finish install I get the same loading bar with the apple log, but this time the bar freezes about 5% (and again, I have left it on for hours with no change).



    I really can’t pinpoint the cause of this problem. Would getting the disk wiped for good neccesarily solve the problem? Should I maybe just put a nail through the motherboard to commit myself to buying a new machine rather than hoping to get anything more out of this one? Will it ever be fast again?

    What steps should I take next?

    Thanks for the help!!!

    Operating System

    Mac OS X 10.9.5 (Build 13F1077)

    Model

    MacBook Pro (Late 2008)

    Processor

    Intel Core 2 Duo T9400 @ 2.53 GHz

    1 processor, 2 cores

    Processor ID

    GenuineIntel Family 6 Model 23 Stepping 6

    L1 Instruction Cache

    32 KB x 2

    L1 Data Cache

    32 KB x 2

    L2 Cache

    6144 KB

    L3 Cache

    0 KB

    Motherboard

    Apple Inc. Mac-F42D86C8 Proto

    BIOS

    Apple Inc. MBP51.88Z.0074.B01.0810311509

    Memory

    8192 MB 1067 MHz DDR3
     
  2. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    Coincidentally, I just ordered a 2012 MBP and Evo 850 today. I was doing my research, saw this post and did some checking on your issues.

    It appears that the 2008 15" is supposed be able to handle 6GB max. The 17" supposedly only handles 4GB, but some are able to use 6GB. So first thing I'd suggest is putting your old RAM back in.

    It could be that the Evo 850 is doing SATA I, instead of SATA II (what the 2008 MBP is capable of). Some SATA III SSD's (the Evo 850) have some problems in some SATA II computers and will revert to SATA I, even if the specs say it is SATA II compatible (which the Evo 850 claims to be). The web shows that some people can get SATA II with the Evo 850 in the 2008 MBP, others can't. I also bought a caddy today and the web shows that some people have problems with the cheaper ones while others don't (the connector would be the problem here). You might want to try switching positions with the HDD to see what kind of speeds you're getting.

    I tried twice to install El Capitan on a disk using a USB 2 stick. It installed but wouldn't boot afterwards. I have no idea why. In my case I was able to run the installation program (which created the bootable stick in the first place) and it worked. (Yes, I should have done that from the start - my bad.) The install program would be on the USB stick you created and is called "Install OS X El Capitan.app". (I believe the program requires Snow Leopard or later.) I ran the program from another disk so I'm assuming there is no difference in the programs. You didn't give information on if you have a running OSX remaining on the non-Evo 850 disk and what's running or not at this point so it's uncertain what's the best course to reinstall El Capitan for you.
     
  3. wavymedia thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #3
    It seems that there was some confusion over whether my model could support 8GB RAM, but in he research that I undertook when I started trying to refurbish my machine 2 months ago I had determined that the 6GB limit was a software limitation of the OS that was available at the time of the machine's release (or something like that).

    Either way the machine recognises 8GB of RAM.

    Well I tried it with just one stick of 4GB (the new corsair RAM that I bought) and hey, it works fine. No slowdown or anything, just the way it should be.

    Then I tried with one 4GB and one of the original 2GB samsung sticks, and the computer crashed and went ****y on startup, displaying the apple logo with lines of weird text code over the top of it (the wierdest error I have ever seen on this computer).

    I also tried with both of the original ram sticks and that too kept crashing (but no three beeps that indicates ram problems).

    So, now I'm still confused.

    Does anyone know?

    Is this machine able to handle 8GB RAM?
    Should I be able to use the 4GB corsair stick alongside a 2GB Samsung stick?
     
  4. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    My quick research when I wrote my first reply was that it couldn't handle 8GB. Just because the computer can recognize 8GB doesn't mean all will be well with 8GB. I would try each of the 4GB sticks separately. If they work fine separately, then you know the computer doesn't work well with 8GB.

    If you post the part #'s of the Corsair and Samsung, or better yet, the specifications - maybe somebody can tell you why they're not working well together. I don't know enough about memory specifications to be able to speculate. For about 20 years now, I've bought directly from Crucial based on what they recommended for my Mac/PC model and have never had a problem. As a result, I haven't spent the time or effort trying to figure out exactly what works, what mix and matches, etc. For the 2008 MBP, Crucial offers and 4GB stick and one or two 2GB sticks. They don't offer a 6GB kit or 8GB option. In that situation, given my research, if it was me, I would have ordered a 4GB and 2GB stick and **hope** I get 6GB, but almost certainly would be able to get 4GB.
     
  5. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #5
    The early 2008 (pre-unibody) only takes 6GB. OP's computer (Late 2008, or first gen unibody) takes 8GB no problem. Please re-check your information.

    OP, I'd do what you said in your first post and go for a clean install. That'd rule out software problems, there's no way that computer should feel slow with a SSD installed.
     
  6. wavymedia, Dec 17, 2015
    Last edited: Dec 17, 2015

    wavymedia thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #6
    OK, so I managed to get up and running with 1 stick of 4GB and one stick of 2GB. It seems that the massive slowdown only occurs with the 2x4GB Crucial sticks (not corsair as I previously thought).

    But why could this be? I was sure that this model was the late 2008 MBP... Maybe I was wrong... Hey, those stats that I got out of geekbench say its a late 2008 model...

    I'm going to switch the sticks round a bit more and see if anything happens...

    I'll try a fresh install soon as well. maybe that'll work now that I'm running smoothly again.

    EDIT: Ok, both the 4GB sticks are working fine on their own... But when they're both in the massive slowdown occurs...

    So I guess all thats left to do is a fresh install. I hope that fixes it because I'm really bored of this ******** now...
     
  7. wavymedia thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #7
    OK, so the fresh install worked, I am now running El Capitan.

    The 8GB RAM is still causing problems, though. With the 8GB on startup a loading bar appears under the apple logo which freezes and the OS does not start up.

    Any other RAM combination works fine. And all the sticks work fine on their own. The best I can do is 4GB + 2GB.

    Weird... This system should be able to handle it. I'm happy my machine is up and working, but I would like the full 8GB that I have paid for.

    Hmm, anyone have any ideas on this?
     
  8. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #8
    I was wrong. The 2008 MBP models are confusing since there are 2 late 2008 models. I actually saw that but when I went to the Crucial site, there was only one selection for late 2008 - BUT WAIT - they also have a listing for 2 late 2008 models and they're not sorted by year so I missed that. In any case, since you have Crucial, their web site says if you got the kit CT3631183, it should work. They have different kit #'s with the same memory and if you didn't get it from Crucial, it may be a different #. But the following are the specs for that memory:

    DDR3 PC3-8500 • CL=7 • Unbuffered • NON-ECC • DDR3-1066 • 1.35V • 512Meg x 64

    If your memory meets those specs, it should work although there could be a problem with your computer. I noticed that the specs for the other late 2008 model is quite different from those above. So check the specs of the memory you have.
     
  9. wavymedia thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #9
    ok, so...

    The crucial RAM sticks I have read CT4G3S1067M.C16FKR 4GB DDR3 - 1066 SODIMM

    Doesn't seem like quite the same thing.

    I couldn't find the model number CT3631183 on the crucial website, maybe because I am on the UK site. I did find this: http://uk.crucial.com/ProductDispla...p_category=&parent_category_rn=&storeId=10153

    All the specs are the same apart from the 1.5V instead of 1.35v.

    Would that be correct?
     
  10. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #10
    Interesting that the UK site recommends the 1.5 V vs. the 1.35 V for the US site. A search on Google indicates that voltage difference isn't a problem.

    Take a look at:

    http://blog.macsales.com/9102-secret-firmware-lets-late-08-macbooks-use-8gb

    This may very well apply to you. The version in your OP is MBP51.88Z.0074.B01.0810311509 and that doesn't look like the most recent EFI version.

    The Apple page is

    https://support.apple.com/en-us/HT201518

    They'll both lead you to the Apple EFI download page. If you have the current EFI version, running the installer will not do the installation. If you do upgrade, follow the instructions carefully when doing an EFI upgrade.
     
  11. wavymedia thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #11
    Wow, thanks treekram, that actually fixed the problem.

    I remember viewing that page a while back before I bought all the new hardware, but it was so long ago that i saw it I must have discounted or forgotten about it, probably because most of the way through trying to do these upgrades I thought it was the SSD causing the problems.

    So now I'm up and running on an SSD with the original HDD as a storage drive, 8GB of RAM and new battery. The trackpad has a big crack through it and gets stuck down if you press it, but I can't be bothered to fix that. My machine also likes to turn itself off at random sometimes, but its been doing that for 4 years and I try my best to pretend that doesn't happen. The screen also likes to flicker occasionally, but thats no biggie.

    I know there isn't much life left in this machine, but hopefully I can find a way to salvage the parts into a new machine when the time comes.

    Thanks a lot for the help everyone! I thought it would never work again but it did!
     
  12. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #12
    I'm glad that worked. Did you get your SSD and OS issues resolved?
     
  13. wavymedia thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #13
    There were never any SSD issues, it was the ram all along. The OS couldn't install with the ram problem, when I temporarily went back to the original 4gb it installed no problem.
     
  14. treekram, Dec 19, 2015
    Last edited: Dec 19, 2015

    treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #14
    So are getting better performance on your SSD than what you had originally?

    WRITE SPEED - 160MB/S - 200MB/S
    READ SPEED - 240MB/S - 250MB/S

    EDIT: Looking at some articles on the web, the read speed is not too far off from the expected maximum of 300 MB/sec. of SATA-2. So it look likes you're all good.
     

Share This Page