My Login Items Keeps Being Deleted

Discussion in 'OS X El Capitan (10.11)' started by Anto38x, Jan 3, 2016.

  1. Anto38x macrumors member

    Anto38x

    Joined:
    Aug 19, 2006
    Location:
    Cork, Ireland
    #1
    Hi all....

    I'm currently running 10.11.3 Beta (15D9c) and everytime I restart my computer my login items disappear.

    I noticed an unusual icon in the Login Items dialog list box.... something called "Letter". I'm wondering if anyone knows what this is or how I can get rid of it. I have deleted it and added my normal startup items all over again and it keeps on re-appearing... and I'm thinking this could be the offending culprit.

    I have also run a thorough virus scan on my main startup Hard Drive using AVG for Mac and nothing was found.

    Anyone got any ideas.... I usually have about 12 startup items that just make my life that bit easier in the morning when I sit at my desk to start work. It's not stopping me working.... but just irritating why this is happening.

    Any suggestions or comments most welcome



    Regards,
    Anthony
     

    Attached Files:

  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    did you check your Applications folder for an app named Letter? perhaps it's preferences are set to 'open at login'... try removing everything from the login items, rebooting, then adding them back one-by-one...
     
  3. Anto38x thread starter macrumors member

    Anto38x

    Joined:
    Aug 19, 2006
    Location:
    Cork, Ireland
    #3
    Hi FisherKing and a Very Happy New Year to You!!

    Thanks for that suggestion.... I should have also said in my post that I tried all those obvious solutions... the Letter icon and App name I have never seen before... so just strange to see it in my startup icons list.

    I tried a search for that App also... and no match.... it must be related to an app running in hidden in the background. I have even tried using the Activity Monitor but nothing obvious has shown up.... is there any trick to find the location of this app in the finder from that Login Items dialog box...?

    Thanks again for your reply and offer of assistance.


    Regards,
    Anthony
     
  4. Anto38x thread starter macrumors member

    Anto38x

    Joined:
    Aug 19, 2006
    Location:
    Cork, Ireland
    #4
    I just found out what that strange icon was... I right clicked on the name of the strange titled icon and it allowed me Show In Finder... and straight away it went to a Resources folder that displayed the familiar icon of DockStar which is a notification utility app I use with OSX Mail.... so that's solved that.... I have been using that for years so it's probably now not what's causing the Startup Login Items disappears.... maybe it's just a Beta glitch that will be resolved in future releases, but this issue was happening before I took the Beta plunge... actually I tried the update to try and hopefully resolve this issue.

    Ahhh well... back to square one with this mysterious issue :)

    Thanks again.


    Regards,
    Anthony
     
  5. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    remove 'clean my mac' from your login items (and make sure the app's preferences are set to NOT open on login...).
     
  6. randomgeeza macrumors 6502

    Joined:
    Aug 12, 2014
    Location:
    United Kingdom
    #6
    TBH, I would remove Clean My Mac, full stop. It may well be that app which is the root-cause of this problem. Apps like that are nothing more than bloatware, and often cause far more problems than the so-called benefits offered.

    OS X manages on its own. Anything that offers to clean, optimize, speed up etc. is BS and not needed.
     
  7. Anto38x thread starter macrumors member

    Anto38x

    Joined:
    Aug 19, 2006
    Location:
    Cork, Ireland
    #7
    Thanks guys.... the issue seems to be a know issue with this Beta release.... hopefully the full public release will resolve this issue back to normal function. I really like CMM3, it always does a great job of keeping my Mac optimised and efficient and it's never caused any issues. I have been using it now for about 2 years.
     
  8. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #8
    I have this issue as well and DO NOT have CleanMyMac installed.... Any advice? I am on 10.11.2.
     

Share This Page