My Mac does not recognize my Canon HF S100 camcorder.

Discussion in 'Digital Video' started by khorsani, Feb 22, 2010.

  1. khorsani macrumors newbie

    Feb 22, 2010
    Hi friends,

    My 2 GHz Intel Core Duo, OS 10.5.8 (not snow leopard) does not recognize my new Canon HF S100 camcorder. I am using FCP 6.0.1 and iMovie 09 and the camera does not appear on either of these software nor on my desktop. I have initialized the memory card on the camera as someone suggested on this forum but nothing happens.

    Any suggestions would be welcome.

  2. frenchlemon macrumors newbie

    Feb 22, 2010
    South of France
    I have the same camera, what kind of SD card are you using? have you tried a different one? I stopped connecting the camera directly since it's a lot slower than using a card reader. Do you have a card reader handy? The volume name is "CANON".
    Oh and v.important note! you can't connect the canon camera to a computer, if the power is not connected to the camera.. it just won't work. (that's the reason I bought a card reader in the first place)

    - connect the power before connecting it to your mac.
    - try a different card.
    - do check disk utility, just in case it's there but not mounted.

    Hope this helps, let us know!

  3. retep47 macrumors newbie

    Feb 23, 2010
    two solutions

    I bought a cardreader and used this one, worked fine
    Newest Finalcut Pro accepts the Cannon recorder, but the older ones do not
  4. khorsani thread starter macrumors newbie

    Feb 22, 2010
    Hi friends, thanks for your replies.

    I have been successful in importing clips from my hf s100 to my FCP 6.0.1.

    Through the apple forum I learned to configure my USB port on the camera and once I did that it was good to go. To configure the USB port on the hf s100, the first time you connect the camera to your computer you want to press the far right silver button on the LCD screen that has the camera image/play button on it. When you do that, it prompts you to select your USB device. In the hf s100's case, you have to select the computer/printer and not the DVD burner. Once I selected computer/printer my computer recognized my camera.

    Thanks for your help.
  5. chris33432 macrumors newbie

    Dec 4, 2012
    I found One solution!

    I have found so many solutions to challenges I've had, that I thought I could share my experience with the canon camcorder and my mac....;)

    I know...., this was explored in 2010. On the other hand the problem has not been resolved. Either I had to buy the Pixela imagemixer ($100), or download it to a pc....!! which I do have... Life isn't perfect!! lol

    I have a Canon Vixia HF R300 it does not give the user a pc/printer option.
    This is what I discovered... Intel macs that have snow leopard (OS10.6) have a little application called "image capture" :D I don't know if this app has appeared before....
    Open it (your camera has to be connected (I used usb) to you computer and to the electricity. And in playback mode) It will show you a list of devices. I selected the canon vixia and then how I wanted it imported. It also asks where you want to store it...its up to you.
    Autoimport, or selecting another program to import and so forth.
    I then opened iMovie and imported the recorded video to edit. I hope this helps.....

Share This Page