My MAC Plus won't start.

Discussion in 'Apple Collectors' started by Garryg, Jul 29, 2009.

  1. Garryg macrumors newbie

    Joined:
    Jul 29, 2009
    #1
    I've got an old Mac Plus that seems to be compleatly dead.
    It used to work OK, but I havend had it switched on for years.
    When I switched it on recently, absolutely nothing happened!

    There seems to be absolutley no power grtting into it atoll.
    This is one of the old Macs that take a double A battery that fits into a slot in the rear of the machine, I've replaced it, on the off chance that it would make a difference, it didn't.
    I also know the power lead works as I used the same one that I use for a VGA monitor.

    I suspect something has went on the power board, is there anything that can easily be checked, and replaced. Or should I just chuck it?
     
  2. MacMini2009 macrumors 68000

    MacMini2009

    Joined:
    May 22, 2009
    Location:
    California
  3. Garryg thread starter macrumors newbie

    Joined:
    Jul 29, 2009
    #3
    Hmmm, any other suggestions?
    I don't think he would return my support-desk calls ;)
     
  4. Mac SK macrumors member

    Joined:
    Sep 23, 2008
    #4
    A new battery is a good start...Lets see, Unplug the power connections on the board and replug them back in. Reseat the ram. Unplug the ribbon off the Hard Drive and try to start up. Does the power supply have the dual voltage switch on the back..slide it one way and then back to 115. Sometimes just repluging stuff in and out will get it going after a long sleep. Good Luck.
     
  5. SuperJudge macrumors 6502

    SuperJudge

    Joined:
    Apr 2, 2008
    Location:
    The Triangle, NC
    #5
    It might live yet!

    For starters, that PRAM battery is not a AA. It's an Eveready 523, also known as 4.5V PX 21, ANSI 1306AP, or IEC 3LR50. If it's dead, that shouldn't make a big difference (because I have a functional Mac Plus on my desk at work that has a mostly dead PRAM battery), but if a AA battery is in it, my guess is that it won't work correctly. So try getting your hands on the right kind of battery. A bit of Google-Fu should find you a source.

    Beyond that, there's nothing particularly easy that comes to mind for troubleshooting.

    If all else fails, you can always make a Macquarium out of it. ;)
     
  6. Garryg thread starter macrumors newbie

    Joined:
    Jul 29, 2009
    #6
    I think it still has the same battery that was in it the last time it worked.
    But surely it should power up whether there is a battery in the (AA sized) slot or not?
    I'm almost posative that I've run this without and batery in the slot before... (but that may have beed the Amstrad PC1512!)


    Absolutely nothing is happening! No power whatsoever, would a dud, wrong or missing battery do that?.

    Does anyone know if there is a site for (preferably fixing) old MACs.

    I used to be a computer technician, so I know my way around a soldering iron, so if I knew what I was looking for I could probably fix a dodgy power board, if that's what it is, and I think it must be (unles it is the battery) :(

    Oh, by the way this machine dosn't have a hard drive in it, only a floppy, I've got a separate SCSI hard drive, and that still powers up.


    Thanks for all the help though.
     
  7. MacTech68, Aug 1, 2009
    Last edited: Jan 30, 2011

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #7
    Since you know your way around a soldering iron, I'll take a punt at something.

    There are two basic versions of the Power/Sweep board. A 120V only version and a 120V/240V version. There are 4 large capacitors on the 120/240V version near the bottom edge.

    On the 120/240V version, along the bottom edge is a 33K ohm resistor that often goes open-circuit. It makes the machine totally dead.

    Obviously, there are many other possible causes, such as the fuse but that resistor was the most common problem for a completely dead board.

    The original resistor is a 33K ohm 1/2Watt carbon.

    The 120V Only board will have a similar resistor but of a different value. It's usually connected across the large 100uF 200V electrolytics to discharge them. It's marked as R41 and is 100K (probably 1/2Watt).

    See this pdf for a circuit at the bottom of page 6 of the 120V ONLY version.

    Good Luck! :)
    ________
    Subaru B9sc
     
  8. Garryg thread starter macrumors newbie

    Joined:
    Jul 29, 2009
    #9
    Thanks, I will buy the resistor next time I'm near Maplins and punt away!

    By the way, the fuse is ok, I checked that, and nothing looks obviously fried.

    'Eat it'... yes... ok... I'll do that then... :confused::D

    Thanks for the link as well, but I'm more interested in fixing it than getting another one, ex-technicians never die... well not untill they stick the soldering iron into the wrong thing :eek:
     
  9. payforbaby macrumors newbie

    Joined:
    Jun 16, 2016
    #10
    I'm also having trouble with a Plus not booting.

    Now, I am admittedly, very inexperienced with older Mac computers, but I recently got one for free and while it's pretty cool, and I did first learn to use computers on one a long, long time ago. I have forgotten everything.

    This one in particular will fire up, "ding" and then it just sounds like it is trying to read from the floppy over and over again. The display is on and showing the "no disk" image (floppy disk with a big "X" through it), but still just keeps trying to boot from the floppy over and over. When I shine a light into the floppy drive, I do see the drive trying to turn a disk (that isn't there) and I notice it seems like the internal mechanism of the floppy drive seems to be hanging a bit "low".

    Any thoughts? My understanding is that this worked perfectly in the past when it was put away a few years ago. It's very clean and it came from someone that takes impeccable care of all of their electronics, so I doubt it was abused in any way.

    Thanks!
     
  10. MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #11
  11. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #12
    Putting them in storage starts the issues. When on and warm, being used they stay less moist and the grease and parts seem to move well until.....not used then it becomes hard like mortar, it must be removed and regreased. After being lubricated lots of dry runs, disk in, disk out popping until travel is smooth to make sure before you put it all back together.
     
  12. payforbaby macrumors newbie

    Joined:
    Jun 16, 2016
    #13
    Thanks for those replies. I finally have some time to sit down and give this a try!
     

Share This Page