My Mac somehow blocked all of Blizzard

Discussion in 'Mac Basics and Help' started by NightStrikergp, Jun 3, 2012.

  1. NightStrikergp macrumors newbie

    Joined:
    Sep 19, 2008
    #1
    This evening, I tried playing Diablo 3 to find that the launcher couldn't connect. After some messing around I found that www.diablo3.com was also down, but not only that, anything connecting to Blizzard was down. So all of blizzards websites, and all the games.

    I thought it was just me so I went into bootcamp Windows 7 and was able to access all Blizzard websites like normal. I also was able to get Blizzard.come and diablo3.com on my iphone and ipad as well as other computers on the network. However my Macbook Pro has decided to block all access to Blizzard.

    I checked the hosts file and saw nothing was added but to make sure I reset it back to it's default format. I restarted, released my IP, reset my modem and router, tried multiple browsers and even did a time machine restore but to no avail.

    As it stands now my Macbook Pro just will not connect to anything Blizzard related, even though every other computer in the house works.

    Does anyone know of anything I can try short of an entire system format/restore? Using Lion as my OS.
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    I'd create a new network location, maybe DNS or something else is wrong?
     

Share This Page