My mac started up in "Localhost:/ root#" and I have no idea how to get out

Discussion in 'macOS' started by skye3000, May 15, 2008.

  1. skye3000 macrumors newbie

    Joined:
    May 15, 2008
    #1
    I'm typing this on my sister in law's computer. Any answer would be greatly appreciated as I have a writeup that I'm working on in the computer and I need to get back to it as soon as possible. Much appreciated.
     
  2. skye3000 thread starter macrumors newbie

    Joined:
    May 15, 2008
    #2
    There's also a CD in there that needs to be ejected for me to use the mac os install disk and I have no idea how to eject it while in this mode.
     
  3. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #3
    More information please. When you say it started up in Localhost:/root# it does not help much. I assume you are talking about the browser seeing as that is almost a standard URL and Localhost refers to the current computer.
     
  4. skye3000 thread starter macrumors newbie

    Joined:
    May 15, 2008
    #4
    I press the power symbol. The screen turns on. I hear the all-too-familiar start-up sound. The screen shows gray and the apple. Then the screen turns black with white text in the top left corner: "localhost:/ root#"
     
  5. Littleodie914 macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #5
    Hmm, weird indeed. To eject the CD, shut down your computer, hold down the mouse/trackpad button, then start it back up, while holding.

    You might just have to boot the defunct computer in target disk mode (hold down "T" while it starts) and plug it into your sister-in-law's computer to get the files off of it, I'm not sure how to fix the problem, save for a wipe and install! :eek: Good luck!
     
  6. skye3000 thread starter macrumors newbie

    Joined:
    May 15, 2008
    #6
    Don't want to sound like an idiot, but how do I boot from CD? I stick in the cd but it goes straight to the black screen before it gets a chance to read it.
     
  7. JNB macrumors 604

    JNB

    Joined:
    Oct 7, 2004
    Location:
    In a Hell predominately of my own making
    #7
    You're in Console.

    First, at the "#" prompt, type exit, then press enter. It might exit Console and load Aqua.

    If that doesn't work, try holding Command-Option-P-R at power up. This resets the Parameter RAM.

    Also, look at this article for recovering. Make sure you note which version of OS (up to 10.4, or above).
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    To boot from a CD, reboot and hold Option at the chime.
     

Share This Page