My Mac will no longer boot!

Discussion in 'Mac Basics and Help' started by benwedge, May 28, 2008.

  1. benwedge macrumors newbie

    Joined:
    May 28, 2008
    #1
    I have a huge problem! I can't get my Mac to boot (even in safe mode!) I changed a folder access permission through terminal, then turned my computer off. Now it won't boot at all!

    Is there any way I can fix this?
     
  2. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #2
    You can try to boot to the OS X DVD (put the disc in the drive and hold down C at the startup chime). Run Disk Utility and try 'Repair Disk Permissions' on your Macintosh HD.

    That might do it if it is a matter of permissions you've changed.
     
  3. benwedge thread starter macrumors newbie

    Joined:
    May 28, 2008
    #3
    Thanks

    Thanks for the quick reply, I'll give it a shot when I get home tomorrow, I'm at a conference, luckily my presentation is backed up on my iDisk! I'll post how it fares tomorrow.
     
  4. gill99msu macrumors newbie

    Joined:
    May 18, 2008
    #4
    My Mac will no longer boot!

    The same thing happened to me. I was ( still am) a newbie. I had owned the mac for less than a month. It would just boot, then loop back and restart everytime. I wasn't very versed in the commands (chmod, chown, etc)at the time.

    I eventually did a re-install but I chose the option to backup my current install to a previous install folder. This worked and got my system booting again. All of my applications were still there, however some needed to be dragged from the dmg file to the applications folder to work properly. Once this was done, I could simply copy the pref file from the previous installation and all my settings were restored. This might not work for everything, but maybe can save you a little time. Who knows, maybe someone here can give you a way to restore the system without having to re-install.

    I had bootcamp as well. I could boot into Windows ok. Then I manually backed up my crucial files from the machintoshHD before doing a re-install.

    I booted from the install DVD and ran repair permissions, but this did not solve my problem.

    Best of Luck to you.
     
  5. benwedge thread starter macrumors newbie

    Joined:
    May 28, 2008
    #5
    Well, so much for saving my data. I checked out all the options, and even went to an Apple store for an opinion. It was unsavable - I corrupted the entire hard drive. Thankfully, all I've lost is about a week of solid work, and a few hundred photos, but it'll be a pain replacing all of that work again, once everything is reinstalled.

    Thanks for the ideas guys, I guess it would have worked any other time.
     

Share This Page