My MacBook doesn't display an Apple webpage properly!

Discussion in 'MacBook' started by Asthmatic Kitty, Nov 5, 2015.

  1. Asthmatic Kitty macrumors member

    Asthmatic Kitty

    Joined:
    Sep 29, 2014
    #1
    Either I'm doing something very dumb or this is a really weird bug.

    I went onto the following page on my MacBook (https://www.apple.com/uk/iphone-6s/design/), and noticed that the text was appearing but the images weren't. Then I tried the same on my iMac but the images appeared on there. I've tried turning off Ghostery on the MacBook, turning Flash back on (and updating), but no change. I'm not sure what else I might've changed on Safari to make this happen. Also tried restarting the computer and emptying the cache in Safari, but again no change. Both Macs are running 10.11.1.

    The images don't appear the whole way down the page, until I get to 'Landscape view on iPhone 6s Plus', after which everything seems to work fine.

    Any ideas? I'm totally baffled.

    Here's a screenshot of what it looks like on the MacBook:

    [​IMG]
     
  2. Dwayne82 macrumors member

    Joined:
    May 16, 2015
    Location:
    Switzerland
    #2
    I can see the pictures on my rMB, OS 10.11.1, Safari 9.0.1
    - What if you turn off Java-script in the security-settings of Safari? Those images are "animated" trough Java. When i turn Java off, the images are still there but they stay on their place. If you can see the pictures this way, there could be something wrong with Java.
    - Can you see the pictures in Firefox or Chrome?
     
  3. Asthmatic Kitty thread starter macrumors member

    Asthmatic Kitty

    Joined:
    Sep 29, 2014
    #3
    Thanks for the reply.

    Turning off Javascript worked! The images display now.
    Now then, any idea how to fix the Javascript?
    Haven't tried in FF/Chrome, don't have them installed.
     
  4. Dwayne82 macrumors member

    Joined:
    May 16, 2015
    Location:
    Switzerland
    #4
    Try the following:
    - Important notice: if you made some specific settings in safari, you have to set them again after this procedure)
    - Quit Safari
    - Move the file "com.apple.safari.plist" to your desktop. The file can be found in "Home/Library/Preferences/" (the "Library" folder is hidden by default. So go to Finder, hold the "option" key and use the "Go" menu to show the "Library" folder)
    - Start Safari (the file "com.apple.safari.plist" will be recreated in the Library).
    - If all went well, you can delete the copy of the file on your desktop

    Just a sidenote:
    Get rid of Adobe Flash, it just uses too much resources of your rMB and makes your Mac less secure. For the specific case you need Flash on a website, install Google Chrome or better: Google Chrome Canary. Both of them have a built-in flash-player which will be updates automatically. Chrome Canary is the developer-version of Google Chrome and uses a little less resources than the power-hungry Chrome. It can be unstable, but it gets updates almost every night.
     
  5. Asthmatic Kitty thread starter macrumors member

    Asthmatic Kitty

    Joined:
    Sep 29, 2014
    #5
    Thanks for that Dwayne. Unfortunately it didn't work :(
    I have a genius appointment on Weds for something different, might take my macbook in then and see if they have any idea. Could this possibly be a hardware problem, or could it only be software?

    Have deleted Adobe Flash like you suggested.
     

Share This Page