my macbook is Fa&^ed

Discussion in 'MacBook' started by dirtymarlow, Dec 3, 2011.

  1. dirtymarlow macrumors newbie

    Joined:
    Dec 3, 2011
    #1
    hi there.
    I have an older macbook, about 08 if i remember correct (possibly 07 model) that i was running snow leopard on. The problems started about 2 months ago when it would just randomly pres the \ key and do crazy stuff with it. I would be typing normally and slashes would just come in any were, i also found that when this was happening i couldn't use the shift key to make a capital O. This was very annoying so i took it back to the apple shop in town (not actually an apple shop but the closest we've got in Adelaide its called next byte if it means anything). It had a new keyboard about 6 months ago due to cracks in the palm rest (this was done under extended warranty), i was hoping that due to the fact the keyboard was stuffing up that they replaced not that long ago there would still be some warranty but apparently not, they wanted far more money than i could afford to fix it so i just let it be and put up with it. I'm glad i didn't have to write anything for uni lol.

    I went away for a week last week and that's when it got progressively worse. the first day i was away it was working reasonably fine, the day after that however i tried to turn it on in the morning and there was a loading bar underneath the apple logo and spinning gear and it took significantly longer to start. The next day the same thing happened however the loading bar went away and the spinning gear and apple were sitting there for a long time so i force shut down tried again and it worked ok. The next day was the same as previous except it took about 3 force shutdowns to get it to work, the next day it was completely cactus and wouldn't load up at all, the apple logo and gear just kept sitting there once the loading bar had disappeared. Sometime in there (it was either the last or second last night) the computer tried to do a software update, it seemed to download fine using the "community" internet, but when it actually tried to install it failed (i cant remember what reason it gave). I think the updates were just for safari and itunes.

    Yesterday i had a good go at trying to fix it, i found a few threads on here along the similar lines so i tried a few things. I tried booting from a disk BUT i borrowed my friends snow leopard when i installed it several years ago so i was trying to boot from my copy of leopard, this didn't work which i kinda thought would be the case. I think my sister has a copy of lion as well as she just bought a new macbook pro, if this is any help. I tried booting in safe mode and this sorta worked but it got to a blue screen and stayed there for a very very long time and then went to a black screen so i force shut down as it didn't seem to be doing anything. I then did the ram reset thing (common, option,p,r i think) and it booted then which i though would have been the fix, so i plugged in my time machine and tried to restore back to last week. I tried for a bit but then told me there was not enough space to go back. Kinda stupidly i decided to restart the computer to see if it was fixed but it wasn't fixed and now its completely buggered. I cant get it to boot in safe mode, like it just loads with the apple, gear and load bar then the bar goes away and it just sits there with the apple and gear literally forever (i left it for about 5 hrs today by accident as i got sidetracked by my car). I've tried doing the ram reset again and it makes all the noises as though it's working but then just does like it is doing in safe mode attempts.

    I'm completely at a wits end now with this and its really pissing me off that i have to use our ****** windows home computer. So do you have any suggestions for me to try to get it to turn on and work? Does the random slashes have anything to do with this?
    A few more things to add that i forgot earlier. On holiday before the loading bar started appearing it had a spaz attack and told me there wasn't enough space on the hard drive to navigate the internet on safari or do anything else at all despite the get info thing saying there was 17 gb free. Also when the slashes started happening the computer wouldn't go to sleep when you shut the lid, it would go into a sort of loop like you could hear the hard drive turn off and then kick back into action and it would just keep doing this. Also I'm trying to get my friends copy of snow leopard again if this helps.
    I think that's all sorry for the huge first post and thanks for any help
    Harry
     
  2. iMacC2D, Dec 3, 2011
    Last edited: Aug 12, 2017
  3. dirtymarlow thread starter macrumors newbie

    Joined:
    Dec 3, 2011
    #3
    thanks for your help. Ill try the thing that you quoted on start up and see what it tells me. the other thing i was thinking, as i have a backup from last week, is there a way to completely wipe the hard drive and reinstall the OS or does the computer actually have to be turned on to do this.
    cheers ill report back the codes it says
    harry
     

Share This Page