My MacBook is lagging like crazy

Discussion in 'MacBook' started by DaVit, Aug 28, 2009.

  1. DaVit macrumors newbie

    Joined:
    Aug 28, 2009
    #1
    Hi, I have a problem. It started first few months ago, sometimes when I watched movie for a long time it started lagging. It didn't happen very often. Than it started happening more often and then even dock started lagging and Dashboard, Exposé and other things. So I decided to reinstall computer but it didn't help. I was hoping that maybe it will stop after I install Snow Leopard but it just got much worse. Everything I do (even writing) is lagging, not to mention that I can't even watch movies or youtube videos. Even switching windows is a problem! I hope you guys will help me because I'm desperate and I don't know what else to do.

    MacBook is late 2007; 2 GHz Intel Core 2 Duo

    Do you think that if I take it to an Apple Store they will help me even tough it's after warranty? There are no Apple Stores in here but I am going to Scotland in a few days.
     
  2. zap2 macrumors 604

    zap2

    Joined:
    Mar 8, 2005
    Location:
    Washington D.C
    #2
    Something similar happened to my brother...he ended up buying a new one.(for college, not because the computer was hopeless) I've now taking it...I've clean install 10.6 on it, and hopefully it will work great! Does you Mac have much HDD space clean? That can slow you down sometimes
     
  3. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #3
    You can definitely try a few things on your side before you contact Apple.

    First, create a new user. This will isolate the problem if it's user or system-wide.

    Second, you can try to delete the Caches folder from your username/Library and then do a restart.

    Third, try to repair permissions.

    Finally, if the above doesn't work, try an Archive and Install without preserving user settings. If that fails, you will then have to bring it Apple to have it looked at.
     
  4. DaVit thread starter macrumors newbie

    Joined:
    Aug 28, 2009
    #4
    I don't know, why should clean install of 10.6 do something different than clean install of 10.5? And my HDD is half empty.

    iLog.Genius: Yes, I already did a clean install and it didn't help. But I was asking if there is any point of bringing it to Apple Store when it's already 2 years old.
     
  5. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #5
    Maybe since you reinstalled it's reindexing (you will see a dot in the Spotlight symbol in the upper right hand corner).

    My Mini was slow until the dot disappeared (I did a wipe and install).
     

Share This Page