My MacBook Pro Randomly Powered On

Discussion in 'MacBook Pro' started by m i k e, Jan 4, 2008.

  1. m i k e macrumors member

    Joined:
    Aug 10, 2007
    #1
    I was sitting across the room and my MacBook Pro SR just randomly powered on. The screen was shut and the only things connected to it were an ethernet cable and the power cable. I don't have wake-on-lan configured for it either so that couldn't be the case. Has this happened to anyone or has anyone heard of this happening?
     
  2. iW00t macrumors 68040

    iW00t

    Joined:
    Nov 7, 2006
    Location:
    Defenders of Apple Guild
    #2
    Was it really powered off or just sleeping?

    It could simply be phoning home to the "Mother Ship" in the middle of the night, don't worry trust Steve Jobs!
     
  3. skyrider007 macrumors 65816

    skyrider007

    Joined:
    Aug 5, 2007
    Location:
    Bangkok
    #3
    The same thing happened on my MBP once and scared the ***** out of me. My MBP was completely shut down and it turned it self on at exactly midnight. It only happened once and I never tried to do anything to fix it though. Maybe software updates could help. If it happens to you frequently then you will need to contact Apple.
     
  4. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
  5. m i k e thread starter macrumors member

    Joined:
    Aug 10, 2007
    #5
    It was completely powered off.

    No alarm set.

    I called Apple and the guy told me to take the battery out, hold down the power button, and reboot. Don't know if that did anything.

    This whole thing was pretty weird. I guess my main concern is that it could be some sort of virus. What do you all think it could be?
     
  6. iMan G5 macrumors member

    Joined:
    Oct 10, 2007
    #6
    There are no viruses for mac osx. Yes proof of concept ones but they aren't in the wild. My iMac wakes up in the middle of the night sometimes. Not from off though. Maybe its checking for a software update.
     
  7. kevo0822 macrumors regular

    Joined:
    Jul 13, 2007
    Location:
    New England
    #7
    Same thing happened to me... but it only happened once, back in November. Hasn't happened again.

    Are you guys by any chance running Leopard?
     

Share This Page