My macbookpro can't see my Seagate HDD anymore.

Discussion in 'MacBook' started by BeeSlayer, Oct 12, 2012.

  1. BeeSlayer, Oct 12, 2012
    Last edited: Oct 13, 2012

    BeeSlayer macrumors newbie

    Joined:
    Oct 12, 2012
    #1
    The Seagate FA Goflex external harddrive can't be recognized by my macbookpro anymore.

    It's in MAC OS JOURNALED format. It was working perfectly on my mac. Last night, my friend hooked it on his PC notebook. He went into Disk Management and clicked to see if it has "online" status on his notebook or not. He probably clicked online/offline a bit but then he changed it to "online" at the end. And that's it.

    BUT now I can't see this HDD on my mac anymore! :eek:

    On Mac: Whenever I connect the HDD it said "The disk you inserted was not readable by this computer". And if I go into Disk Utilities, the disk image is there but I can't verify or rapair it. But everything else is able to do (such as, erase or RAID).

    I installed SEAGATE DRIVE SETTING hoping to reinstall the driver or something like that. But still, the seagate software couldn't do anything because it can't see the HDD.


    On PC: I still can see the HDD in Disk Management but as usual I can't do anything to it.

    I installed the SEATOOLS FOR WINDOWS and ran the checking on it. Seatools can see the drive and the checking ran fine on HDD.

    But still, I can't see it on my mac.

    ---------
    Problem is I can't format the disk. I have this important copy of work on it that can't be deleted whatsoever.

    PLEASE HELP! :confused:

    NOTE: I'm on MacBook Pro. OS 10.6.8 Snow Leopard.

    Edited: to say that I ran Disk Warrior and it couldn't see the drive. That didn't help.
     
  2. BeeSlayer thread starter macrumors newbie

    Joined:
    Oct 12, 2012
    #2
    Please helppppp....the files in there are extremely important.

    Last night, I tried Disk Rescue 3 app. It can see the HDD but after scanning and everything, my mac still can't see this HDD. I tried cloning the drive to another HDD but the files in there were larger than another HDD. :(

    It's so frustrating! What happened? Just one hook on PC and now nothing can see it? Do i need to go back and fix it in PC somehow?
     

Share This Page