My Mad Mac Strikes again! (+ Radeon 9700 success)

Discussion in 'PowerPC Macs' started by KawaiiAurora, Feb 21, 2017.

  1. KawaiiAurora macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #1
    I have 3 possible reasons why my Mac is behaving this way

    • It doesn't wanna run OS X Leopard at all costs
    • It's an attention whore
    • It's simply defective!
    Let's go a step back now :)

    As some of you may know, my Sawtooth had a defective Rage 128 Pro inside it. OpenGL applications/games looked all garbled and some didn't even bother doing anything (white screen). OS X Tiger booted but upon upgrading to 10.4.6, applications started to close all the time randomly (every 5 seconds..) but I found a fix. I had to replace CoreGraphics.framework in ApplicationSupport.framework. OpenGL stuff was still messed up but that's the price you must pay when working with defective hardware.

    Now, since I love my mad mac, I decided to buy a Radeon 9700 for it. Waited about 2 weeks and bam, it arrived (along with 3 other cards; got a good deal off eBay). Took the R9700 out, put it in my Mac, flashed it via VNC with its ROM, crossed my fingers, prayed and viola! OS X booted and the ripple effect worked (QE/CI got enabled). The "Chess" app that comes bundled with OS X didn't have graphical issues anymore and CorePlayer worked just fine. "Awesome!" I thought, my Mac's issues are over; yeah right..

    Today, I decided to act on my dream of having OS X Leopard (my fave OS) on my Sawtooth and I hit a brick wall of course. Started up a defective OS X Leopard Single Layer DVD, it booted but I got red stripes on the screen... "Must be the DVD I thought..". After that, I copied a Leopard DMG (installed OS) onto a pendrive and restored it via Disk Utility on OS X Tiger... The moment of truth! I booted the Mac up after 2 hours of copying and straight into the wall!

    OS X booted alright, grey background was up BUT then, it happened.. The Leopard intro movie came up and a bunch of white stripes were on the video and right clicking revealed a red striped context menu. Quite odd how the cursors weren't affected by the stripes and the stripes were only present on the video, not on the top and bottom of the screen where there was no video. The video kept on looping sadly so I couldn't set up OS X Leopard, I tried Safe Mode (holding Shift at bootup) but that didn't do much as nothing came up on screen except for a grey background with a normal cursor.

    Interesting fact: Leopard's intro video was really choppy. Anyways, I decided to nuke the Leopard install and installed Tiger. Tiger installed no problem but when I updated to 10.4.11, my Mac decided to be an idiot once more and the random crash issue showed its ugly heads again.. Did all the updates, replaced the framework and viola! (Again). Tux Racer, Aqua Man, CorePlayer, Duke3D and Chess don't have any artifacts!

    Can anyone help in my investigation as to why my Mac hates Leopard and why I need to do the framework fix?

    Specs:

    • 400MHz G4 CPU (7400)
    • 576MB RAM
    • 128MB Radeon 9700
    • 10GB IDE HDD (original HDD)
    • Bad CMOS battery (holds no charge)
    P.S: Will the Sims 2 run at a bearable speed or am I better off playing The Sims 1 on this Mac to preserve my sanity? (Using the framework fix on Leopard doesn't work; it's good enough that a 10.4.5 framework works on 10.4.11 without any issues..)

    Thanks,
    Aurora

    I hope you like the added bit of humour to lighten up the mood :)
     
  2. lclev macrumors regular

    lclev

    Joined:
    Jul 29, 2013
    Location:
    Ohio
    #2
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    That is true, but it is possible to load Leopard on a 400mhz G4. I've done it on a TiBook and we have a G4 Sawtooth (AGP) at work that is running it.

    The more serious limitation is ram. I woudn't use anything less than 1GB of ram - although the Mac I mentioned at work is now only using less than 512mb of ram.
     
  4. KawaiiAurora thread starter macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #4
    My main issue isn't the RAM (or CPU speed) tho.. The video issues are my main concern tbh
     
  5. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #5
    Yeah, I don't know what to say about that. Because of the way things work I would speculate that the CPU is handling a lot of the graphic processing (instead of the video card) and that because of the lack of CPU speed and ram you are therefore experiencing graphic glitches.

    But.

    My 450/G4 at work has less than 512mb of ram and is running Leopard just fine. So, this has to be something else. And I don't know what that might be.
     
  6. flyrod macrumors 6502

    flyrod

    Joined:
    Jan 12, 2015
    #6
    I'm guessing you taped over the 8x pins on the video card? What does it have for cooling? You could try a lower GPU speed and see if that helps. From your description it sounds like it gets hot and has problems. The 9700s seemed to run hot so they need pretty good cooling. I think I lot of them had external power via a molex too. Is that hooked up?
     
  7. KawaiiAurora, Feb 22, 2017
    Last edited: Feb 22, 2017

    KawaiiAurora thread starter macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #7

    Nope, I have a Sawtooth so I did not taping. It has a fan that's a tad loud but the issues appear when you boot up the computer too so I doubt that it's because of too much heat. Yeah, the FDA cable is hooked up :) (one of the capicators is a bit bent, could that be the issue?)

    (I doubt it's the GPU tho because the framework issue appeared with the R128 Pro too. Kinda odd how I got the same issue (the framework issue) on the R9700 too; kinda strange since nobody else had it so probably something is screwing up.. memtest says RAM is okay tho)

    Could it be the PRAM battery? - That's the screen I get
     

    Attached Files:

  8. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #8
    The CPU & RAM requirements versus user experience for Leopard have already been discussed here,
    but I noticed the OSX Leopard requirements include:
    9GB of available disk space <---Not sure, but could this be a concern future installs?
    ...or maybe not if the install was "Custom" with any subjective bloatware unchecked.

    Hmmm....that last image you uploaded -- reddish desktop, does seem video card related
    (seated firmly, driver, available power from PSU, heat, etc).

    Anyway, here's the system requirements for The Sims 2 on PPC:

    System Requirements
    Mac OS X 10.3.8 or later
    PowerPC G4/G5, 1.2 GHz or faster
    256 MB RAM
    3 GB free disk space
    Video Card (ATI): Radeon 9000 or better
    Video Card (nVIDIA): Geforce FX 5200 or better
    Video Memory (VRAM): 32 MB or higher
    DVD drive required to install and play

    Recommended System Requirements
    The Sims 2 runs best on an iMac G5 or Power Mac G5 with 512MB of RAM and 64MB of VRAM.
     
  9. 128keaton macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013

Share This Page