My Magic Mouse refuses to act like one.

Discussion in 'macOS' started by Sergeant Pepper, Dec 25, 2009.

  1. Sergeant Pepper macrumors member

    Joined:
    Jan 28, 2009
    #1
    So, I got a Magic Mouse for Christmas. Which would be awesome, except that my MacBook won't recognize that it's a Magic Mouse. I installed the Wireless Mouse Update 1.0 from Apple and restarted my system (Snow Leopard 10.6.2, by the way). I then followed the instructions in the Quick Start guide for switching from a USB mouse to a Magic Mouse, which are as follows:

    1) Slide the On/Off switch on the bottom of your Apple Magic Mouse to turn it on. No problems so far.

    2) Choose Apple () > System Preferences, and then click Mouse. Still going fine.

    3) Click "Set Up Bluetooth Mouse..." in the lower-right corner. Easy peasy.

    4) Select your mouse, and then follow the onscreen instructions to pair it with your Mac. This is where the problems start. It shows up as "Apple Wireless Mouse," so I click the "Continue" button, but no onscreen instructions appear. It just kicks me back to the Mouse preference pane, with the same options as before. Aren't I supposed to get a pane with Magic-Mouse-specific options?

    Also, MagicPrefs doesn't recognize that there is a Magic Mouse connected. The mouse works, I can click and move the cursor and everything, but the system doesn't seem to recognize that it's a Magic Mouse.

    Any help is greatly appreciated.

    EDIT: Problem solved. I just had to uninstall USB Overdrive and everything worked perfectly.
     
  2. jumbb macrumors regular

    Joined:
    May 1, 2010
    #2
    This is happening to me!! how did you do it? I don't get anything about a usb overdrive... :(
     
  3. Sergeant Pepper thread starter macrumors member

    Joined:
    Jan 28, 2009
    #3
    USB Overdrive is a program designed for use with USB mice that lets you assign custom functions to extra buttons your USB mouse might have. If you have it installed, it conflicts with the Magic Mouse.

    If you don't have it installed, I have no idea how to help because that's what my problem was.
     

Share This Page