My main account dissapeared!!

Discussion in 'MacBook Pro' started by madhusudhan, Jun 2, 2009.

  1. madhusudhan macrumors newbie

    Joined:
    Jun 2, 2009
    #1
    All

    I have MBP Leapord 10.x about 18months old.

    When I restarted last night, I only see Guest account on my login screen!

    I tried several things including SafeBoot but couldn't get to anything.

    I can only login to machine by Guest access - but obviously this account is useless to do anything.

    I tried to change account preferences when logged in as Guest - when tried to unlock the padlock, I was asked to input admin's credentials. It didn't like them (I know for sure they are correct)

    I am not sure the cause or solution for this problem. Can someone guide me as to what I can do to retrieve my account details (I will also be happy to hear out the reasons behind for such things)

    Unfortunately I only have one main (admin) account on the system.

    Thanks a lot
    Madhu
     
  2. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #2
    When you went into System Preferences as the Guest user, were you still able to see your account show up under the "Accounts" preference?
     
  3. madhusudhan thread starter macrumors newbie

    Joined:
    Jun 2, 2009
    #3
    Nope, I can't see my account listed there except the Guest account :(
     
  4. John89 macrumors regular

    Joined:
    Dec 23, 2008
    Location:
    Scotland
    #4
    Do you see your account under (hard drive name) > Users in Finder?
     
  5. madhusudhan thread starter macrumors newbie

    Joined:
    Jun 2, 2009
    #5
    No, I can't see (except Guest).

    I can see my username under /Users though (using terminal). Also I can see the PS2 on the terminal set to my username too.
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Did you try removing the PS2 then, it sounds like that conflicted with your account and your account lost.

    Try removing/deleting the PS2 stuff, reboot off your install disks and see if you can repair your userid. AFAIK you should be able to setup a new account using your install disks, though I never tried that.
     
  7. madhusudhan thread starter macrumors newbie

    Joined:
    Jun 2, 2009
    #7
    This is what I did - I used install disks to create a new account. When I tried creating an account wiht the same as my lost account, it did not create it.

    When doing so, a popup said that do I want to associate this new account with the existing account - I said yes, but nothing happend :(

    Although I have created a new account, I am unable to open up the <old_account>.sparsebundle file when logged in as new user (however, I could open the bundle using root though)

    So, can some one guide me how to grab the data under my old account to new account? There's hell lot of data (just about 5Gg remaining on a 200Gb HDD), so logging in as root and copying them to new account's folder isn't feasible.

    BTW, thanks to all you guys who responded!

    Thanks
    Madhu
     
  8. bmcgrath macrumors 65816

    bmcgrath

    Joined:
    Oct 5, 2006
    Location:
    London, United Kingdom
  9. madhusudhan thread starter macrumors newbie

    Joined:
    Jun 2, 2009
    #9
    No, I didn't do that - was a bit scared to do so as I thought might corrupt the data.

    Will it corrupt or is it okay to do so?
     
  10. modular macrumors regular

    Joined:
    Apr 10, 2009
    #10
    i had this happen to me a couple years ago. I think it was on tiger. I had it even worse though, when I restarted this one time, it started up as if it was the first time I turned on the computer (welcome animation and setup screen). I had to boot it up in firewire mode with another computer and get my file, and reinstall the operating system. there may be an easier way, but thats what I had to do to fix the problem.

    at lease you have a guest account you can loginto.
     

Share This Page