My MBA 2011 13'' cannot write on SD card

Discussion in 'MacBook Air' started by moikeyy, Oct 29, 2011.

  1. moikeyy macrumors member

    moikeyy

    Joined:
    Sep 21, 2011
    #1
    So I have purchased an RiDATA 32gb SDHC and my mac cannot seem to write on it. I have checked everything..

    1. The lock/unlock switch, tried both
    2. Even tried putting the switch halfway
    3. Tried reformatting the card via digital camera
    4. Tried reformatting the card via disk utility but the erase option cannot be clicked

    I need your opinions on this veteran apple people, thank you :)
     
  2. jamesr19 macrumors 6502

    Joined:
    Nov 7, 2009
    #2
    Try another SD card and then you can determine if it's a problem with the card or a problem with the mac. If it's the mac then off to the genius bar you'll go as it's likely it's hardware. If you're out of warranty then eBay it is for a usb card reader
     
  3. drugrep macrumors newbie

    Joined:
    May 28, 2011
    #3
    I believe Apple has a problem with SD readers on 2011 MacBooks.

    Mine won't mount. I have inserted several new SD cards right from package.

    I can't even get them to read when I boot to Windows 7.

    If you search the internet, many are having this issue, I believe there is a defect.
     
  4. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #4
    I haven't had any problem formatting SD cards in mine. Primarily I have been formatting them either Mac OS Extended (Journaled) or Mac OS Extended (Journaled, Encrypted) depending on my needs. I have only formatted 4, but no issues with them.

    What was the result when you attempted to format the card in camera? Did it format successfully at that point? If so, at least that rules out an issue with the card.
     

Share This Page