my mbp 2010 suddenly cannot detect sd card

Discussion in 'MacBook Pro' started by iamadreamer, Nov 13, 2010.

  1. iamadreamer macrumors newbie

    Joined:
    Jun 23, 2010
    #1
    hello all,

    It has been several weeks that I didn't transfer my files from my sd-card (8GB sandisk) to mbp, but today when I tried to plugged the sdcard to my mbp, it just didn't detect the sd-card. Then I tried 2 other sd-cards that I have and they are also cannot be detected. The mbp just didn't response at all (just like nothing is plugged to the sd-card reader). If I use usb external card reader, the sd-card can be read no problem at all.. :( :( does it mean that the built-in sd-card reader is broken? Anybody has experienced this problem?
     
  2. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #2
    I am now seeing the same issue. Not sure where to even begin looking...
     
  3. ECUpirate44 macrumors 603

    ECUpirate44

    Joined:
    Mar 22, 2010
    Location:
    NC
  4. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #4
    Running a TM Backup at the moment. But when it is done I will reboot and see if that corrects the issue.

    Under System Profiler I see "This computer doesn't contain any Apple Internal Memory Card Readers." Under Card Readers. Which I am pretty sure isn't right.
     
  5. J&JPolangin macrumors 68030

    Joined:
    Jul 5, 2008
    Location:
    Thule GL @ the TOW
    #5
    Have you rebooted your machine since accidentally "uninstalling" the card reader?

    A reboot should re-detect the "new hardware"...
     
  6. NZed macrumors 65816

    NZed

    Joined:
    Jan 24, 2011
    Location:
    Canada, Eh?
    #6
    its a pretty old post and its replied today lol
    anyways maybe the wire that connects the SD reader to the Mainboard or whatsoever is faulty! so maybe going to the Apple Store is a considerable choice(if your machine is bought within a year)!
     
  7. ajacc macrumors newbie

    Joined:
    Nov 2, 2010
    #7
    SD Trouble

    Hi there, had the same problem recently with my 2010Imac (built in reader). SD card not docking card in finder. In fact not seeing card anywhere etc.:mad:

    Did a bit of digging about and narrowed issue down to the use of Virtual Machines, in my case Parallels. It appears that the SD card was linked to the virtual machine not to the OSx. Don't ask me why or how.

    Anyway, the following worked for me....

    In OSx insert SD card, yes nothing happens! Leave card in reader, start VM. Within windows environment top drop down menu 'Devices'. Select USB. Select card reader. Now should be bale to see contents of SD card. At this stage I also opened Iphoto and Finder all side by side and was able drag SD card photos into both reader and Iphoto events just as precaution. Photos went across ok.

    Now, back in windows, close SD card window. Go back to drop down devices and there should be a tick against card reader. Deselect tick. This (i think) told windows to stop looking at SD reader and allowed OSx to see it.

    I closed VM, opened finder and voila! finder sees SD card.

    Ensure you eject card in finder before pulling card out otherwise you are back to square 1.

    Hope that helps:)
     

Share This Page