My mbp behaves strangely !

Discussion in 'MacBook Pro' started by sioannou, Nov 17, 2011.

  1. sioannou macrumors member

    sioannou

    Joined:
    Mar 25, 2010
    Location:
    Nicosia Cyprus
    #1
    Hi guys,

    I have an early 2011 base MBP 15" and all of a sudden it started to behave strangely. At first when i fresh powered it up in the morning after login the screen was completely black. The solution I found for this was to press cmd+f2 and f1 to turn off screen brightness and add it again.


    Now, that I've solved that problem another one came up. For example when I hold down any key the letter does not repeat itself. For example if i press x and hold it down i don't get xxxxxx. Some keys behave like this , but others behave normally for example uuuuuuuu or sssssss.

    To be clear I did not spill anything on the mac or something else. The computer was in my office in a bag.

    Please I'd appreciate any help.
    Thanks.

    Sotiris
     
  2. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #2
    Pouting?

    We all behave strangely at times, especially when stressed. Judging from your sig. you have been giving that 'puter a lot of love and then you left it in the bag! :eek: It may just be pouting. :D
    Seriously, that sounds like you need to visit the shrinks (opps, meant to type Genius) at the local Apple store for a proper diagnosis.
     
  3. sioannou thread starter macrumors member

    sioannou

    Joined:
    Mar 25, 2010
    Location:
    Nicosia Cyprus
    #3
    noooooooo what you mean? I can not live without the computer for a day , especially now that I have to deliver the final year project of the uni. Unfortunately I don't have apple store in my country so i have to visit asaap for repairs. If this is something it can be solved by me and not a hardware failure I could fix it :(
     
  4. Ant.honey macrumors regular

    Joined:
    Oct 14, 2008
    Location:
    New York City
  5. MVRL macrumors regular

    MVRL

    Joined:
    Oct 17, 2011
    #5
    I think that is a feature in OSX Lion, you can turn it off in Preferences.
     
  6. sioannou thread starter macrumors member

    sioannou

    Joined:
    Mar 25, 2010
    Location:
    Nicosia Cyprus
    #6
    Do you know exactly where I could find this setting? Actually I don't think is a preference matter as it randomly working for some keys and for some not.

    For example for letter a it may work and later not work :p
     

Share This Page