My MBP now says MacBookPro (2)

Discussion in 'MacBook Pro' started by iapplelove, Oct 23, 2014.

  1. iapplelove macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #1
    Just notcied now seems like across all my icloud devices and the Mac itself it seems to be titled My Mac Book Pro with a (2) after it??

    If I'm on find my iPhone it reads iPhone and iPad titles but puts a (2) after my Mac.

    Even if I'm in my Macs settings and it's looking for BT peripherals it says pair with Mac Book Pro (2). Never did this before I'm thinking it happened after Yosemite,anyone's advice as to why it's reading this why would be greatly appreciated ??

    :apple:
     
  2. gavinstubbs09 macrumors 65816

    gavinstubbs09

    Joined:
    Feb 17, 2013
    Location:
    NorCal boonies ~~~by Reno sorta
    #2
    When I reinstall the OS on either of my MBPs it'll say Gavin Stubbs's MacBook Pro and Gavin's MacBook Pro for the mac that I recently installed 10.10 on, and on my other one I named it cMBP and that's how it appears.

    I would go to System Preferences, Sharing, then change the name. Then on everything else it should see it as the new name.
     

    Attached Files:

  3. iapplelove thread starter macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #3
    Thanks just did that! I changed it in a few places but that seemed to be the main place lol...wonder why it changed.
     
  4. skaeroastro macrumors newbie

    skaeroastro

    Joined:
    Jul 9, 2014
    Location:
    bot lane
    #4
    Hehe I was just about to post and then you posted, but do you own another MacBook Pro or have you connected to a network that has other Macs on it recently? If that's the case, it most likely happened because there's another mac on the network with the same computer name, so your computer prevents conflicts by adding (2) to the end of your mac name.
     
  5. iapplelove thread starter macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #5
    nope it is my only Mac and the only Mac on my network which is strange. I had a few smaller issues after updating but i'm pretty sure the (2) started right after Yosemite.
     
  6. Xenden macrumors regular

    Joined:
    Jun 14, 2013
    Location:
    Rio Rancho, NM
    #6
    I've had this issue since installing the beta of Yosemite in the summer. I didn't really link this to Yosemite until reading this thread. Makes sense though. I've had my macbook pro have (2), (3), and (4). But I also have an iMac and my brother has an iMac; all on the same network.

    Hopefully Apple figures this all out in time.
     
  7. iapplelove thread starter macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #7
    so the computer went back to using (2) after my Mac Book Pro. had to switch it back
     
  8. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #8
    Here is how to fix it, (there is another similar thread on here)

    Go to Network Preferences:

    Click the Location Menu

    Click Automatic

    Click the little Gear

    Click Rename location

    Name the location the same as your computer name (with out the 2,3,4, etc...)

    Go in to Sharing and make sure your Computer name matches the location exactly.

    This worked for me.
     
  9. iapplelove thread starter macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #9

    Thanks man gonna give this fix a try!
     

Share This Page