My MBP won't boot up anymore

Discussion in 'MacBook Pro' started by slapple, Oct 23, 2013.

  1. slapple macrumors 6502

    Joined:
    Jul 25, 2008
    #1
    I have a late 2011 MBP running Boot Camp with Windows 7 and Mac OS X Lion. I was booted into Windows 7 when the screen went black and the computer died. I powered up the MBP again and pressed D to enter Apple Hardware Test. I ran the extended test and it said everything was OK. Then I restarted the computer and saw the white screen, then the screen went black and did nothing. Maybe after 30 seconds, I heard the fan turn on and it got louder. Now the screen is still black, but the fan is running, but nothing is happening. The light on the Caps Lock key doesn't turn on when I press it.

    How do I diagnose this problem? I heard you cannot run a Live Linux CD or the Ultimate Boot CD since Macs don't have a BIOS.

    I really hope the hard drive didn't die. Does the fact that I could run Apple Hardware Test mean the hard drive is OK?
     
  2. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #2
    Try holding the option key right after the mac chimes, then try booting into mac OS X. If you can't get to the point where you can choose to do that, take your computer to the apple store.

    EDIT: you can boot into the ubuntu cd and ultimate dvd, otherwise you couldn't have windows on it either, just boot holding the "c" key.
     
  3. slapple thread starter macrumors 6502

    Joined:
    Jul 25, 2008
    #3
    OK, I tried restarting and pressing Option and then selecting "Macintosh HD" and the screen turned white and nothing happened for several minutes. Then I powered off and tried it one more time, and it booted successfully into Mac OS X! I could even see the Windows partition in Finder.

    So I told Mac OS X to restart in Windows, and then I got the Windows screen saying it didn't shut down properly and if I wanted to boot in safe mode. I told it to boot normally and now I'm back in Windows!

    Looks like everything is OK now, I hope. Not sure why it wouldn't boot up at all before I tried pressing Option on power up, but thanks for mentioning that!
     

Share This Page