My MBP wont read my SD card.

Discussion in 'Mac Basics and Help' started by buggsy13, Jun 20, 2012.

  1. buggsy13 macrumors newbie

    Joined:
    Jun 20, 2012
    #1
    OK, so I did a lot of searching before I made this thread, and none of the tips that I found worked for me, so this is sort of last resort. Anyway, the title says it all, my Mac wont read my SD card. I've been using the card for well over six months with no problems, and then all of the sudden it just stopped showing up. I've tried reformatting the card in my camera, cleaning the SD card slot in my computer, and only putting the card in 3/4 of the way, all to no avail. :( Now I know the card is good, because my camera reads it with no issues. However, I tried using a different card and my Mac did in fact read it, so it seems to be an issue with just this one card. :confused: Any ideas? Thanks.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. buggsy13, Jun 20, 2012
    Last edited: Jun 20, 2012

    buggsy13 thread starter macrumors newbie

    Joined:
    Jun 20, 2012
    #3
    My 4GB PNY does not work, and my 2GB Vivitar does work. As I said, the 4GB used to work fine until now.
     
  4. nuckinfutz macrumors 603

    nuckinfutz

    Joined:
    Jul 3, 2002
    Location:
    Middle Earth
    #4
    Interesting I just read the new review on the Retina MBP on anandtech.com and he specifically mentioned how flakey the SD card reader was on former MBP. Said he had to wiggle it a bit to get some to connect.
     
  5. Edie Brickell macrumors member

    Joined:
    Apr 22, 2010
    #5
    Try your card with different Mac machine may be it will be read by another Mac.
     
  6. LizKat macrumors 68040

    LizKat

    Joined:
    Aug 5, 2004
    Location:
    Catskill Mountains
    #6
    My mid-2010 Mac Book Pro is about to get sent back to Apple for having a dead SD card reader. Both of the new 32GB cards I tried in it do not register. They both register just fine in my MacBook Air (late 2011).

    This MBP must have been made on a bad Monday for someone... it originally arrived with a dead power port :( so it went back for that. Then it went back for bad WiFi (not just connectivity issues, but throwing errors to the log) :mad: and they replaced that. Then it went back for bad optical drive :mad: :mad: and they replaced that. Now the SD reader :eek: which I sure wish I had thought to check out before I sent it back for the optical drive.

    Meanwhile on each repair trip the rep has assured me that they completely check out the machine before sending it back. No longer sure what "completely check the machine out" actually means. Maybe it means "it boots" in which case saying it's a "complete" check is way past overstatement.

    Going to rename this mid-2010 baby "MyLemon" pretty soon. I have never before had this kind of experience with a Mac and I've been buying them and driving them into the ground since 1984. Most of them NEVER went in for a fix, lasted at least five years and even then were good enough to give to a neighbor's kid after a drive wipe and fresh OS install.

    I'm almost ready to chuck this machine into kitchen recipe server status when it comes back, and get a refurb late 2011 2.8GHz i7 MBP to have a more reliable (maybe?) workhorse. I've been thinking about that lately anyway since I don't think I want an rMBP. So if I go that route and the late-2011 MBP doesn't work out better than this mid-2010 seems to be doing, I don't know what I will do. Stick with the Air line going forward, maybe. I'm just as mad as a hornet right now. I feel sorry for the next person I bump into today if I don't get a grip and chill out... heading off to make a tall iced coffee!! Sorry :eek: for the drift from thread topic to overall rant. Thank goodness I got AppleCare on the machine.
     
  7. Lancer macrumors 68020

    Lancer

    Joined:
    Jul 22, 2002
    Location:
    Australia
    #7
    Also having an issue with the SD reader on our MBP, the previous model (Late 2011) don't use it that much but wanted to on the weekend and it would not read the Sandisk 1Gb. Have not tried other brands, but we did use a SD to USB card reader and it worked right away so it's not the SD card and the MBP like it, just not through the SD reader. To me it sounds like the reader slot is not working, could it be dirty?
     

Share This Page