My mouse won't click! (10.4.11)

Discussion in 'macOS' started by malcolmffc, Oct 30, 2007.

  1. malcolmffc macrumors member

    Joined:
    Oct 30, 2007
    #1
    Yesterday I restarted my PowerMac G5 (dual 2.7Ghz) as normal. When it rebooted my system wouldn't respond to mouse clicks. I can move the pointer around the screen and the system even responds to mouseover events (e.g. the text when you move over an application in the Dock) but it won't respond to clicks. Funny thing is, I tried VNCing in from another computer on my LAN and clicking DOES work from there.

    Any ideas guys? I've taken the obvious step of repairing permissions, to no avail. I'm using 10.4.10 and wasn't doing aything unusual or stupid beforehand as far as I know.

    Thanks!
     
  2. sammich macrumors 601

    sammich

    Joined:
    Sep 26, 2006
    Location:
    Sarcasmville.
    #2
    10.4.11 typo? Or are you a beta tester? :eek:

    That aside, have you tried a different mouse on the same machine? Perhaps the mouse clicker mechanism is broken? That said, it could be software related, but I can't think of anything atm. I'll get back to you...
     
  3. malcolmffc thread starter macrumors member

    Joined:
    Oct 30, 2007
    #3
    Sorry, yes I meant 10.4.10.

    I did try the mouse on a different machine (my MacBook Pro) and it worked fine. So it's not a problem with the mouse itself.
     
  4. Mr.Noisy macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #4
    Just a thought, you haven't changed the settings in mouse preferences by accident have you ? i had a problem a while back with the scroll button not working, but after using a screen cleaner to rub over it and turn it a while it was just dirt blocking it.
     
  5. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #5
    Is it a Bluetooth mouse? Mine occasionally did this in 10.4.10 and I found turning it off and back on again seemed to fix the problem
     
  6. ghking macrumors regular

    ghking

    Joined:
    Jul 21, 2007
    #6
    this same thing happened to me literally 5 minutes ago. What worked for me was just shut down the host computer through the vnc client. while it is off, quit VNCthing, then restart the host.
     
  7. peistah macrumors newbie

    Joined:
    Nov 11, 2010
    #7
    Phil A.

    You are a genius, I was trying all different things, even turning the computer off did not work, turning the blue tooth mouse off and on worked like a charm!
    :D
     

Share This Page