My new Macbook Pro 17" i7 - Bluetooth Problem!!

Discussion in 'MacBook Pro' started by floppysock, Apr 20, 2010.

  1. floppysock macrumors newbie

    Joined:
    Mar 17, 2010
    #1
    Hi all,

    I have mroogled this but didnt come up with anything.....

    I managed to get my hands on my new baby last Friday...... new MBP 17" i7 with anti-glare!

    My wife also has a 2009 uMBP 13", which I have been using since Xmas while waiting for Arrandale!

    I use a stand with a apple wireless keyboard and wireless magic mouse.

    I have been having problems with the new 17" machine - the mouse and kb work fine for about 30 mins then the mouse gets really slow and jerky.... and the keyboard gets slow as well and starts displaying double / triple keys when typing etc. The only way to resolve the problem is to reboot. If I unpair the mouse and keyboard and repair this doesnt fix it - only a reboot works.

    I phoned applecare and they instructed to create a new test user, which I did - same problems.

    Reinstalled OSX (machine was only 2 days old though!), and this didnt fix it. So, I took the machine back to my Apple Retail store and swapped it for a new machine.

    Finally finished setting it up again yesterday, and the problem started AGAIN - ARRRRGGGGGHHHHHH!

    So it would seem that unless I have had two faulty machines (highly unlikely) it must be software related? I have been trying to work out what might be causing it - but running the machine without Parallels, Little Snitch, 1 Passowrd....... things which I thought could have been related to the problem..... no luck.

    I basically ran the same system on my wifes 13" before I got the new machine and I had no problems with the mouse and keyboard......

    BTW : I have also changed the batteries on both the mouse and keyboard.

    Anyone else having this annoying problem?
     
  2. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #2
    Do you run Time Machine wirelessly?

    I had a similar problem w/ my C2D MBP. When Time Machine ran, and I was connected to my network via 2.4GHz WiFi, the BT keyboard/mouse would act weird.

    Connecting to my network via 5.0GHz WiFi fixed the issue for me.

    Probably not the issue you're having, but just in case...
     
  3. floppysock thread starter macrumors newbie

    Joined:
    Mar 17, 2010
    #3
    No unfortunately, my only wifi is my netgear router for my internet...........
     
  4. L0u1s macrumors newbie

    Joined:
    Mar 21, 2009
  5. floppysock thread starter macrumors newbie

    Joined:
    Mar 17, 2010
    #5
    Already done that as per my post. Just got off the second phone call with Apple (90 mins!)...... has been escalated to the Engineering Division......

    Wierd and annoying problem.
     
  6. sth macrumors 6502a

    Joined:
    Aug 9, 2006
    Location:
    The old world
    #6
    Could be a problem with 10.6.3 in general:
    On my "late '06" MBP the Magic Mouse sometimes stutters for a few seconds since the update.
    A colleague's "early '08" MBP has mouse/keyboard issues with 10.6.3, making it unusable after a time.
     
  7. churinoff macrumors newbie

    Joined:
    Apr 25, 2010
    Location:
    NC
    #7
    Same bluetooth problem

    My brand new 15" i7MacBook Pro has the same bluetooth problem - My old Apple bluetooth keyboard worked OK for a day or two then began sending multiple letters or not connecting or connecting slowly.

    My brand new Apple bluetooth mouse however has exhibited no problems. Was your keyboard also an older model?

    I noticed another similarity - I installed the latest Paralells Desktop 5. My batteries in both the keyboard registers around 80% Battery Level.

    Please post any solutions - I do need to keep typing and the bluetooth keyboard is far superior for me.
     
  8. harmonica01 macrumors 6502

    Joined:
    Jul 30, 2007
    #8
    I notice this after about 2 hours of usage.

    The way to alleviate it as I've found is turn blue tooth off before you put cpu to sleep and make sure your magic mouse and wireless keyboard are also off.

    Turn those both on, then wake the computer and I haven't had the same problem yet even with the uptime right now at 32 hours.

    We shouldn't have to do this, but likesay is how I got rid of the sudden lag after a few hours of use on my i7 15"
     
  9. churinoff macrumors newbie

    Joined:
    Apr 25, 2010
    Location:
    NC
    #9
    Thanks harmonica01,

    I am writing this reply on my bluetooth keyboard! A hassle indeed if I have to do it each time I put the MBP to sleep but worth the effort until a software solution emerges (I hope). Thanks again.

    I hope to call Apple support tomorrow and se if the folks there can put this problem in the pipeline for a solution in an upcoming update.

    I did notice this is a unique build number for OS X 10.6.3 and maybe this problem will be overcome in 10.6.4
     
  10. Blue Sun macrumors 6502a

    Joined:
    Feb 11, 2009
    Location:
    Australia
    #10
    A bluetooth firmware update for the new i5 and i7 MBP's will most likely resolve this issue. Chances are the Apple engineers you mentioned are already working on a fix.
     
  11. churinoff macrumors newbie

    Joined:
    Apr 25, 2010
    Location:
    NC
    #11
    Thanks Blue Sun,

    I will mention a firmware update for bluetooth when I talk to Apple.

    I also was wondering if the new placement of antennas (I believe I read they are now near the CD-DVD opening) might have had some effect but reorienting my keyboard brought no relief.
     
  12. harmonica01 macrumors 6502

    Joined:
    Jul 30, 2007
    #12
    I dont think its signal strength problem at all. In my review I was using the magic mouse and wireless keyboard in my lap more than 10 feet, possibly more like 15 feet away from the computer. Laptop hooked into my TV downstairs with plenty of interference there having it in middle shelf of my entertainment tower. All was working fine. Something in the firmware as mentioned is just choosing to "sleep" at inopportune times, but likesay, my stupid fix works for now as aggravating as it is.
     
  13. TheLonelyIsland macrumors member

    TheLonelyIsland

    Joined:
    Jan 25, 2009
    Location:
    I'm On A Boat.
    #13
    I too have problems with connections between the Wireless Keyboard and my new i5 Mbp. I have the 3 battery version.
     
  14. postman14 macrumors newbie

    Joined:
    Apr 26, 2010
    #14
    Had the same problem. Then I switched the channel in my Netgear-Router (Wireless Settings -> Wireless Network -> Channel).
    Now it worked for 5 hours without this problem!
     
  15. Guy Mancuso macrumors 6502a

    Joined:
    Mar 28, 2009
    #15
    Sounds like interference . I would change channel on router and also where is your wife's laptop in all this. If it is close by you could be running into it also. i had three laptops in my office the other day and the mouse did not know what to do since it was paired with those before.
     
  16. grtmagnet macrumors newbie

    Joined:
    Apr 28, 2010
    #16
    bluetooth troubleshooting tips

    definitely sounds like interference could be an issue here... here's some things I do when troubleshooting Bluetooth devices:

    1) Read the RSSI for your devices: option click on the Bluetooth menu extra -- you should see "RSSI: -57 dBm" or something similar. anything approaching -70 or lower would be poor strength, and you should either move your devices closer or make sure you are using 5ghz on your access point, if possible/available. The lower the RSSI number, the more likely WiFi traffic will cause interference. If you device is right next to or in front of your laptop, I would expect to at least have RSSI values in the -40 to -60 range.

    2) if you have Apple Developer software packages installed, you can launch the application at:

    /Developer/Applications/Utilities/Bluetooth Explorer.app

    and open the "Connection Quality Monitor" window. click Start and then you can watch the RSSI go up and down as you move your devices around. move them into positions that have higher "Raw RSSI" values.

    3) move your access point into using the 5 ghz frequency if possible; then you won't be interfering with Bluetooth traffic at all.

    4) switch the 2.4ghz channel used on your access point (as someone pointed out). Channel 1 and 11 are the best because they don't overlap as many Bluetooth channel frequencies. So if WiFi is interfering, it should not do so as much.

    5) kernel.log -- open Console.app, then look for /private/var/log/kernel.log and system.log files. any interesting messages in there regarding Bluetooth or USB?

    6) look for other interference sources -- microwaves, cordless phones, multiple WiFi access points nearby, etc. turn them off if possible.

    good luck!
     
  17. califguy macrumors newbie

    Joined:
    Oct 1, 2009
    #17
    Have you posted in the Apple Discussion forums

    Paste your system.log and kernel.log around the time the issue occurs. Have you tried posting in the Apple Discussion forums ?
     

Share This Page