My Note 3 not recognized as device/ USB on Mac!

Discussion in 'Alternatives to iOS and iOS Devices' started by MBX, Nov 16, 2013.

  1. MBX macrumors 65816

    Joined:
    Sep 14, 2006
    #1
    Ok so no matter what I do, my Galaxy Note 3 is not recognized as device on my Mac.

    It does not show as USB device and neither it's detected by Android apps such as: Kies, Android File Transfer or Helium.

    The phone is charging when connected to the USB port.

    So what exactly is wrong. Is my Mac missing some drivers for this phone? I tried to install drivers via Kies but it still doesn't connect it.

    I'm running Snow Leopard 10.6.x

    Let me know if there are some OS-X settings I need to do or if I can download any drivers in order for my Note 3 to be recognized?

    Thanks!
     
  2. WilliamBateman macrumors regular

    Joined:
    Nov 7, 2013
    #2
    Download Airdroid in the Play store and on your computer. So much better and wireless :)
     
  3. MBX thread starter macrumors 65816

    Joined:
    Sep 14, 2006
    #3
    Yeah but it's using WiFi. Sucks to use Wifi to transfer Gigabytes of data.


     

Share This Page